Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 181265 - Add filter warnings possibility into the output window
Add filter warnings possibility into the output window
Status: RESOLVED WONTFIX
Product: projects
Classification: Unclassified
Component: Ant
6.x
PC Mac OS X
: P3 (vote)
: 7.1
Assigned To: Jesse Glick
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-26 05:48 UTC by Tomas Zezula
Modified: 2011-05-20 14:00 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Zezula 2010-02-26 05:48:27 UTC
From off line discussion:
Would be great if window with compile output could filter out warnings and show errors only or provide some other means to quickly navigate in the output. This problem is really annoying for me and likely for other JDK developers who tries to use NB to compile JRE parts. Obviously as JRE developer i have to compile code that uses sun.* and this generates tons of warnings. Finding single error among thousand of warnings is *very* annoying.

Probably requires changes on both sides (console and and logger). Jesse, feel free to reassign.
Comment 1 Jesse Glick 2010-02-26 10:03:05 UTC
You can set Ant Verbosity to a less verbose value. (Settings available from button in Output Window.) That affects all builds.

But in this case the problem is the OpenJDK build scripts. These need to be passing a special compiler flag to disable warnings about usage of sun.* packages. I know jdk/make/netbeans/common/shared.xml uses -XDignore.symbol.file=true but I am not sure if this is the right flag or if there is another. (Ideally warnings about sun.* would simply be one -Xlint suboption.)

Note that there is also a bug filed for javac to queue up warning messages and only display them if there are no errors, or at least to put the errors at the top or bottom of the list so they are easy to find. Note also that the NB Ant integration automatically stops scrolling the OW when (what appears to be) the first "hard" error message is printed.
Comment 2 Jesse Glick 2011-05-19 15:37:44 UTC
Why was this reopened? Comment #1 explains what needs to happen in OpenJDK build scripts.
Comment 3 Tomas Zezula 2011-05-20 14:00:18 UTC
As far as I remember Igor wanted to have a filter which can filter out the warnings from the output.
But if the javac Messager will print first errors and then warning. It's OK to keep it as WONTFIX.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo