Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 179456 - Parsing infrastructure locked during startup with JSF files
Parsing infrastructure locked during startup with JSF files
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: JSF Editor
6.x
PC Mac OS X
: P2 (vote)
: 6.x
Assigned To: Marek Fukala
issues@javaee
68patch1-verified
:
: 179320 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-13 07:32 UTC by Marek Fukala
Modified: 2010-03-25 21:55 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
The threaddump (109.42 KB, text/plain)
2010-01-13 07:33 UTC, Marek Fukala
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marek Fukala 2010-01-13 07:32:35 UTC
Just restarted netbeans with some xhtml files with JSF content opened. There is an incorrect model and lock access, see the threaddump.
Comment 1 Marek Fukala 2010-01-13 07:33:01 UTC
Created attachment 93252 [details]
The threaddump
Comment 2 Marek Fukala 2010-01-14 09:40:30 UTC
fixed in web-main#e9caef8c3002
Comment 3 pgebauer 2010-01-14 11:36:19 UTC
Since the issue hasn't been verified in the trunk yet, the whiteboard is set back to 68patch-candidate.
Comment 4 Jindrich Sedek 2010-01-18 06:57:41 UTC
verified (looks save)
NetBeans IDE Dev (Build 201001180201)
Comment 5 Quality Engineering 2010-01-18 23:35:40 UTC
Integrated into 'main-golden', will be available in build *201001190201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/e9caef8c3002
User: Marek Fukala <mfukala@netbeans.org>
Log: #179456 -  Parsing infrastructure locked during startup with JSF files
Comment 6 pgebauer 2010-01-20 14:08:24 UTC
The fix has been ported into the release68_fixes repository.
http://hg.netbeans.org/release68_fixes/rev/c28f0e027939
Comment 7 David Konecny 2010-03-25 21:55:09 UTC
*** Bug 179320 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo