Bug 179320 - Deadlock during shutdown
Deadlock during shutdown
Status: RESOLVED DUPLICATE of bug 179456
Product: javaee
Classification: Unclassified
Component: EJB
6.x
PC Linux
: P2 (vote)
: TBD
Assigned To: Andrey Yamkovoy
issues@javaee
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-08 09:52 UTC by Jesse Glick
Modified: 2010-03-25 21:55 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump of deadlock (97.04 KB, text/plain)
2010-01-08 09:53 UTC, Jesse Glick
Details
Log file (64.91 KB, text/plain)
2010-01-08 09:54 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2010-01-08 09:52:51 UTC
No idea how to reproduce. I had been trying the Calculator sample apps using GFv3. They seemed to hang during the deployment build; I tried to stop the builds without success. When I tried to shut down the IDE, it just froze.
Comment 1 Jesse Glick 2010-01-08 09:53:19 UTC
Created attachment 93139 [details]
Thread dump of deadlock
Comment 2 Jesse Glick 2010-01-08 09:54:33 UTC
Created attachment 93140 [details]
Log file
Comment 3 Jesse Glick 2010-01-08 10:01:52 UTC
Happened to me again after killing & restarting IDE. I ran Calculator app pair - all worked. Then I closed these and made a RESTful Hello World sample and tried to run that (without restarting GF). Hung during Ant build; Run > Stop Build showed "aborted" in the OW but the OW tab did not close; and closing IDE failed. Still unsure how to reproduce from scratch, however.
Comment 4 Petr Jiricka 2010-03-25 14:51:40 UTC
Lots of EJB classes in this thread dump - Andrey, can you please investigate?
Comment 5 David Konecny 2010-03-25 20:11:11 UTC
re. "Lots of EJB classes in this thread dump" - issue 182811 will address problem with too many requests in default RequestProcessor from EjbsNodeFactory.

The problem is that WebAppMetadataModelImpl.getMetadata is blocking task "Parsing & Indexing Loop" from finishing because it posted runnable to default request processor but queue of default RP is full of EjbsNodeFactory tasks which wait back on parsing task. Fixing issue 182811 may (if not resolve this) make this deadlock less frequent. But real cause might be in org.netbeans.modules.web.jsf.editor.index.JsfIndexer$Factory.scanFinished(JsfIndexer.java:136) which should perhaps execute its job to its own thread and not in "Parsing and Indexing Look"? Passing to Marek to have a evaluate.
Comment 6 Marek Fukala 2010-03-25 20:54:40 UTC
(In reply to comment #5)

> make this deadlock less frequent. But real cause might be in
> org.netbeans.modules.web.jsf.editor.index.JsfIndexer$Factory.scanFinished(JsfIndexer.java:136)
> which should perhaps execute its job to its own thread and not in "Parsing and
> Indexing Look"? Passing to Marek to have a evaluate.

This cannot happen after January 14th - see e9caef8c3002 and the already fixed  Bug 179456 -  Parsing infrastructure locked during startup with JSF files
Comment 7 David Konecny 2010-03-25 21:55:09 UTC

*** This bug has been marked as a duplicate of bug 179456 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo