Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 178300 - After changing sync from Smart Secure Copy to Sharing, changes in code aren't reflected on remote host
After changing sync from Smart Secure Copy to Sharing, changes in code aren'...
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Remote
6.x
PC Solaris
: P2 (vote)
: 6.x
Assigned To: Vladimir Kvashin
issues@cnd
68patch1-verified
:
: 178936 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-08 07:55 UTC by Vladimir Kvashin
Modified: 2010-01-28 04:19 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Kvashin 2009-12-08 07:55:06 UTC
Steps to reproduce:
- Set up a remote host with smart secure copy synchronization.
- Set this host for a project, compile and run it. Everything is ok.
- Change sync to "Sharing" for this project
- Make changes in code and try running it - changes aren't reflected in build

Also, changing path mapping has no effect after that.
Comment 1 Vladimir Kvashin 2009-12-08 07:58:05 UTC
The reason is that PathMap is cached in RemoteHostInfoProviderFactory, so FixedPathMap sticks forever (until IDE restart).

The workaround: restart IDE
Comment 2 Vladimir Kvashin 2009-12-08 13:32:26 UTC
fixed in cnd-main:
http://hg.netbeans.org/cnd-main/rev/b7f8c4ac5cc4
Comment 3 Quality Engineering 2009-12-10 02:27:28 UTC
Integrated into 'main-golden', will be available in build *200912100200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/b7f8c4ac5cc4
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: fixed #178300 - After changing sync from Smart Secure Copy to Sharing, changes in code aren't reflected on remote host
Comment 4 Vladimir Kvashin 2009-12-22 09:19:48 UTC
*** Bug 178936 has been marked as a duplicate of this bug. ***
Comment 5 Alexander Pepin 2010-01-13 07:31:57 UTC
verified in trunk build 201001120200
Comment 6 pgebauer 2010-01-14 04:32:12 UTC
The fix has been ported into the release68_fixes repository.
http://hg.netbeans.org/release68_fixes/rev/e76e9e54aa7e
Comment 7 Alexander Pepin 2010-01-26 08:48:43 UTC
fix failed in patch1 candidate 20100126 build.
It seems that the provided changeset was wrong.
Comment 8 Vladimir Kvashin 2010-01-26 09:08:17 UTC
I'm sorry, I provided a wrong changeset.
The proper one is 
http://hg.netbeans.org/cnd-main/rev/8d97333d8b6b
Comment 9 pgebauer 2010-01-27 01:45:12 UTC
The fix http://hg.netbeans.org/release68_fixes/rev/e76e9e54aa7e has been rolled back from the release68_fixes repository.
http://hg.netbeans.org/release68_fixes/rev/6a82ebd844c9

The fix 8d97333d8b6b has been ported into the release68_fixes repository.
http://hg.netbeans.org/release68_fixes/rev/5cebc7da6f33
Comment 10 Alexander Pepin 2010-01-28 04:19:07 UTC
verified in patch1 build 20100128


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo