Bug 177178 - Separated on some lines text is not properly formatted
Separated on some lines text is not properly formatted
Status: VERIFIED FIXED
Product: javafx
Classification: Unclassified
Component: Editor
6.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: Anton Chechel
issues@javafx
68patch1-verified
:
Depends on:
Blocks: 173487
  Show dependency treegraph
 
Reported: 2009-11-19 03:34 UTC by Alexandr Scherbatiy
Modified: 2010-01-26 03:24 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandr Scherbatiy 2009-11-19 03:34:28 UTC
Product Version         = NetBeans IDE Dev (Build 200911180645) (#99dcd4880fda)
  Operating System        = Windows XP version 5.1 running on x86
  Java; VM; Vendor        = 1.6.0_15; Java HotSpot(TM) Client VM 14.1-b02; Sun
Microsystems Inc.


Steps to reproduce:

- Format the code
-----------------------------------------------
import javafx.scene.text.Text;

Text {
    content: 'Sequence level1 = new Sequence();\n'
              'Text text0 = new Text();\n'
              'text0.text = "Wird erreicht durch "\n'
              'Sequence level2 = new Sequence();\n'
                                 'Text text1 = new Text();\n'
              'text1.text="neue Constructor-Syntax \n'
              'level2.add (text1);\n'
              'Text text2 = new Text();\n'
                     'text2.text="Sequenzen,";\n'
              'level2.add (text2);\n'
                           'Text text3 = new Text();\n'
              'text3.text="und funktionale Sprachelemente.";\n'
              'level2.add (text3);\n'
              'text0.items = level1;\n'
                        'Outline outline = new Outline();\n'
              'outline.items = level1;\n'
              'Html html = new Html();\n'
              'Sequence childs = new Sequence();\n'
                             'childs.add (html);\n'
              'html.childs = childs\n';
}

-----------------------------------------------

The result is:
-----------------------------------------------
Text {
    content: 'Sequence level1 = new Sequence();\n'
'Text text0 = new Text();\n'
              'text0.text = "Wird erreicht durch "\n'
              'Sequence level2 = new Sequence();\n'
                                 'Text text1 = new Text();\n'
              'text1.text="neue Constructor-Syntax \n'
              'level2.add (text1);\n'
              'Text text2 = new Text();\n'
                     'text2.text="Sequenzen,";\n'
              'level2.add (text2);\n'
                           'Text text3 = new Text();\n'
              'text3.text="und funktionale Sprachelemente.";\n'
              'level2.add (text3);\n'
              'text0.items = level1;\n'
                        'Outline outline = new Outline();\n'
              'outline.items = level1;\n'
              'Html html = new Html();\n'
              'Sequence childs = new Sequence();\n'
                             'childs.add (html);\n'
              'html.childs = childs\n';
}
-----------------------------------------------
Comment 1 Anton Chechel 2009-11-26 08:58:26 UTC
fixed
http://hg.netbeans.org/javafx/rev/fa0b83951c10
Comment 2 Alexandr Scherbatiy 2009-12-11 05:14:29 UTC
The issue is reproduced in NetBeans-JavaFX-Soma:  #62
Comment 3 Anton Chechel 2009-12-14 08:15:00 UTC
fixed
http://hg.netbeans.org/javafx/rev/f25af541c4ab
Comment 4 Alexandr Scherbatiy 2009-12-17 03:50:06 UTC
verified in NetBeans-dev-javafx-main-123-on-091217-full.zip
Comment 5 Anton Chechel 2010-01-12 06:06:50 UTC
another related changeset: http://hg.netbeans.org/javafx/rev/4abe741fd253
Comment 7 Petr Suchomel 2010-01-15 03:49:14 UTC
Fixed in release68_fixes
http://hg.netbeans.org/javafx/rev/d37b785f9dcf
Comment 8 Alexandr Scherbatiy 2010-01-26 03:24:43 UTC
Verified in NB 6.8 patch1 2010-01-25_21-27-59


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo