Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 176044 - org.netbeans.modules.j2ee.deployment.plugins.api.InstanceCreationException: 0 handlers registered, no handlers for [/local/softs/glassfish/3.0-68/glassfish]deployer:gfv3ee6:localhost:4848
org.netbeans.modules.j2ee.deployment.plugins.api.InstanceCreationException: 0...
Status: RESOLVED DUPLICATE of bug 175932
Product: serverplugins
Classification: Unclassified
Component: GlassFish
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Vince Kraemer
issues@serverplugins
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
: 168012 (view as bug list)
Depends on: 177061
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-05 13:17 UTC by pdeville
Modified: 2009-11-22 16:41 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.37 KB, text/plain)
2009-11-05 13:18 UTC, pdeville
Details
stacktrace (6.30 KB, text/plain)
2009-11-11 07:16 UTC, matusdekanek
Details
stacktrace (6.20 KB, text/plain)
2009-11-11 09:51 UTC, swpalmer
Details
stacktrace (6.19 KB, text/plain)
2009-11-12 08:18 UTC, Jindrich Sedek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pdeville 2009-11-05 13:17:49 UTC
This issue was originally marked as duplicate of issue 162214, that is already resolved. This issue is still valid, so this seems to be another issue, but it might be related.

Build: NetBeans IDE 6.8 Beta (Build 200910212001)
VM: Java HotSpot(TM) 64-Bit Server VM, 14.3-b01, Java(TM) SE Runtime Environment, 1.6.0_17-b04
OS: Linux, 2.6.31-14-generic, amd64

User Comments:
ovk: - started new IDE;
- went to Services and activated ruby by adding GF3;
- created and run ruby app;
- removed GF3 from IDE;
- activated J2EE and Web;->exception during activatioon

pdeville: just opening maven project

mithridates: Started 6.8 beta on Mac OS for the first time (Importing settings from 6.7)



Stacktrace: 
org.netbeans.modules.j2ee.deployment.plugins.api.InstanceCreationException: 0 handlers registered, no handlers for [/local/softs/glassfish/3.0-68/glassfish]deployer:gfv3ee6:localhost:4848
        at org.netbeans.modules.j2ee.deployment.impl.ServerRegistry.addInstanceImpl(ServerRegistry.java:466)
        at org.netbeans.modules.j2ee.deployment.impl.ServerRegistry.addInstance(ServerRegistry.java:360)
        at org.netbeans.modules.j2ee.deployment.plugins.api.InstanceProperties.createInstancePropertiesWithoutUI(InstanceProperties.java:260)
        at org.netbeans.modules.glassfish.javaee.JavaEEServerModuleFactory.createModule(JavaEEServerModuleFactory.java:117)
        at org.netbeans.modules.glassfish.common.GlassfishInstance.updateFactories(GlassfishInstance.java:180)
        at org.netbeans.modules.glassfish.common.GlassfishInstance.resultChanged(GlassfishInstance.java:200)
Comment 1 pdeville 2009-11-05 13:18:13 UTC
Created attachment 90513 [details]
stacktrace
Comment 2 Exceptions Reporter 2009-11-09 10:17:47 UTC
This issue already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=161547
Comment 3 matusdekanek 2009-11-11 07:16:14 UTC
Created attachment 90797 [details]
stacktrace
Comment 4 Exceptions Reporter 2009-11-11 07:16:21 UTC
This issue already has 6 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=161547
Comment 5 swpalmer 2009-11-11 09:51:29 UTC
Created attachment 90829 [details]
stacktrace
Comment 6 Exceptions Reporter 2009-11-11 09:51:36 UTC
This issue already has 7 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=161547
Comment 7 Jindrich Sedek 2009-11-12 08:18:19 UTC
Created attachment 90910 [details]
stacktrace
Comment 8 Exceptions Reporter 2009-11-12 08:18:26 UTC
This issue already has 8 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=161547
Comment 9 Vince Kraemer 2009-11-12 09:35:56 UTC
the ST related to this issue has over 150 'similars' spread over the last year and a half.

It is also the root cause of bug 176534.

Raising the priority to p2.
Comment 10 Vince Kraemer 2009-11-12 09:37:59 UTC
*** Bug 176534 has been marked as a duplicate of this bug. ***
Comment 11 Vince Kraemer 2009-11-12 10:48:16 UTC
*** Bug 168012 has been marked as a duplicate of this bug. ***
Comment 12 Vince Kraemer 2009-11-14 09:06:24 UTC
This is likely to show up in main-golden some day...

http://hg.netbeans.org/web-main/rev/d1f1271297b2
Comment 13 Quality Engineering 2009-11-16 03:23:05 UTC
Integrated into 'main-golden', will be available in build *200911160201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/d1f1271297b2
User: Vince Kraemer <vkraemer@netbeans.org>
Log: #176044: the 0 handler problem
Comment 14 meme 2009-11-22 10:41:06 UTC
Bug is still "available" in current netbeans-dev (200911211401).
Comment 15 meme 2009-11-22 10:42:48 UTC
For further details: Exception #305978
Comment 16 Vince Kraemer 2009-11-22 16:41:50 UTC
this is getting addressed as part of changes for bug 175932, so I am closing this as a dup of that bug.

*** This bug has been marked as a duplicate of bug 175932 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo