Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 176534 - [glassfish, ergonomics] glassfish server is recognized by IDE, but cannot be asigned to a web project
[glassfish, ergonomics] glassfish server is recognized by IDE, but cannot be ...
Status: RESOLVED DUPLICATE of bug 175932
Product: serverplugins
Classification: Unclassified
Component: GlassFish
6.x
PC Windows Vista
: P2 (vote)
: 6.x
Assigned To: Vince Kraemer
issues@serverplugins
: RANDOM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-11 07:36 UTC by matusdekanek
Modified: 2009-11-18 09:28 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
messages.log (120.95 KB, text/plain)
2009-11-11 07:36 UTC, matusdekanek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description matusdekanek 2009-11-11 07:36:07 UTC
Created attachment 90804 [details]
messages.log

Product Version: NetBeans IDE Dev (Build 200911091156)
Java: 1.6.0_16; Java HotSpot(TM) Client VM 14.2-b01
System: Windows Vista version 6.0 running on x86; Cp1252; en_US (nb)

-install IDE (with glassfish)
-create a new web project (wait for actiovation of j2ee)
Glassfish server is listed in main menu|tools|servers.
Despite this it is not possible to assign glassfish server to the project, because it is not listed in the list of available web servers (project properties, run tab). Also it is not possible to assign it to any older opened project, even if the project had previously set glassfish as it`s web server.

After the restart of the IDE everything works fine. 

It is the same under windows xp. Haven`t tried under linux, but guess is, it would be similar.
Comment 1 Vince Kraemer 2009-11-11 10:10:36 UTC
this is a plugin issue... and pretty serious from the sounds of it.
Comment 2 Vince Kraemer 2009-11-11 10:59:50 UTC
please attach the netbeans.conf file...

You will probably  find it in 

c:\Program Filed\NetBeans Dev 200911091156\etc\netbeans.conf
Comment 3 Vince Kraemer 2009-11-11 20:55:54 UTC
OK. I was not able to reproduce this issue on Mac OS X and Solaris earlier today.

I just tried on Vista and could not reproduce the problem.

I will keep working on it, but have a couple questions for you...

1. did you import settings from 6.7?

2. did you reuse your user directory from an earlier 6.8 install?

3. which distribution did you install? [it looks like you installed the 'All' distribution]

4. what are the specs of your environment? Is the machine old (slow) or state-of-the-art new (fast)?

If you do install another nightly build and run into this again, please let me know ab
Comment 4 Vince Kraemer 2009-11-11 20:58:15 UTC
marking as random for now.
Comment 5 Vince Kraemer 2009-11-12 09:37:59 UTC

*** This bug has been marked as a duplicate of bug 176044 ***
Comment 6 matusdekanek 2009-11-13 03:10:21 UTC
1. did you import settings from 6.7?
no

2. did you reuse your user directory from an earlier 6.8 install?
no, otherwise the j2ee would be activated

3. which distribution did you install? [it looks like you installed the 'All'
distribution]
yes, it was the 'all' distribution

4. what are the specs of your environment? Is the machine old (slow) or
state-of-the-art new (fast)?
well, it is older, but I wouldn`t say it is slow. p4 at 2.8 GHz, 1GB RAM. XP was running natively, Vista on Virtualbox machine (that was slow).

I will post the netbeans.conf once I log in to windows (now I am working on linux). I have not changed it, so it should be the same as it was after installation.

I agree, it might be random, sometimes I cannot reproduce it.
Comment 7 matusdekanek 2009-11-13 09:13:10 UTC
I was trying, but could not reproduce it today...

Product Version: NetBeans IDE Dev (Build 200911091156)
Java: 1.6.0_16; Java HotSpot(TM) Client VM 14.2-b01
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)
Comment 8 matusdekanek 2009-11-18 08:56:49 UTC
I have repeatedly reproduced it on linux. 
-start IDE with clean userdir
-open a java application (activates java se)
-open a java web application (activates java ee)
And there it is, the glassfish server is not available in the projects.

The duplicate issue (bug 176044) was already resolved, but this one is still valid. Because of this I think this issue can be reopened.

Product Version: NetBeans IDE Dev (Build 200911171401)
Java: 1.6.0_16; Java HotSpot(TM) Client VM 14.2-b01
System: Linux version 2.6.31-14-generic running on i386; UTF-8; en_US (nb)
Comment 9 Vince Kraemer 2009-11-18 09:28:17 UTC

*** This bug has been marked as a duplicate of bug 175932 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo