Bug 174274 - InterruptedException at java.lang.Object.wait
InterruptedException at java.lang.Object.wait
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jesse Glick
issues@projects
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
: THREAD
: 183808 (view as bug list)
Depends on:
Blocks: 163295
  Show dependency treegraph
 
Reported: 2009-10-10 05:14 UTC by quidryan
Modified: 2010-04-12 14:41 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.83 KB, text/plain)
2009-10-10 05:14 UTC, quidryan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description quidryan 2009-10-10 05:14:18 UTC
This issue was originally marked as duplicate of issue 163295, that is already resolved. This issue is still valid, so this seems to be another issue, but it might be related.

Build: NetBeans IDE 6.7.1 (Build 200907230233)
VM: Java HotSpot(TM) Client VM, 14.2-b01, Java(TM) SE Runtime Environment, 1.6.0_16-b01
OS: Linux, 2.6.28-15-server, i386

User Comments:
quidryan: Tried to stop "Attaching Debugger"



Stacktrace: 
java.lang.InterruptedException
        at java.lang.Object.wait(Object.java:0)
        at java.lang.Object.wait(Object.java:485)
        at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:244)
        at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:227)
        at org.openide.util.Mutex.readAccess(Mutex.java:327)
        at org.netbeans.api.project.ProjectManager.findProject(ProjectManager.java:227)
Comment 1 quidryan 2009-10-10 05:14:23 UTC
Created attachment 89245 [details]
stacktrace
Comment 2 Antonin Nebuzelsky 2010-03-29 14:11:16 UTC
Change of default owner.
Comment 3 Jesse Glick 2010-04-08 22:02:25 UTC
Seems to be due to project load operations being interrupted by Ant process termination. Should just exit early in this case.
Comment 4 Jesse Glick 2010-04-08 22:06:48 UTC
core-main #20c2c8d3171e
Comment 5 Jesse Glick 2010-04-12 14:41:58 UTC
*** Bug 183808 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo