Bug 173917 - [68cat] [debug] Unable to find rdebug_ide
[68cat] [debug] Unable to find rdebug_ide
Status: RESOLVED DUPLICATE of bug 171338
Product: ruby
Classification: Unclassified
Component: Code
6.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: Erno Mononen
issues@ruby
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-06 21:35 UTC by esmithbss
Modified: 2009-10-07 10:16 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
IDE Log File (31.29 KB, text/plain)
2009-10-06 21:36 UTC, esmithbss
Details
Screenshot of directory showing rdebug-ide file being requested (28.18 KB, image/png)
2009-10-06 21:40 UTC, esmithbss
Details

Note You need to log in before you can comment on or make changes to this bug.
Description esmithbss 2009-10-06 21:35:06 UTC
[ BUILD # : 200910010513 ]
[ JDK VERSION : 1.6.* ]

I am attempting to debug under Windows and every time I launch under
JRuby 1.3.1, the system tells me it has a timeout attaching.  The
additional error indicates it is unable to load rdebug_ide.

SEVERE [org.rubyforge.debugcommons.Util]: Error Output: 
C:\Program Files\NetBeans Dev
200910010513\ruby2\jruby-1.3.1\bin\rdebug-ide:19:in `load': No such
file to load -- "C:/Program Files/NetBeans Dev
200910010513/ruby2/jruby-1.3.1/lib/ruby/gems/1.8/gems/ruby-debug-ide-0
.4.6/bin/rdebug-ide" (LoadError)
        from C:\Program Files\NetBeans Dev
200910010513\ruby2\jruby-1.3.1\bin\rdebug-ide:19


I have walked the directory tree and the file is indeed in the right
location with a reported size of 2.26 KB (2,321 bytes).
Comment 1 esmithbss 2009-10-06 21:36:57 UTC
Created attachment 88949 [details]
IDE Log File
Comment 2 esmithbss 2009-10-06 21:40:53 UTC
Created attachment 88950 [details]
Screenshot of directory showing rdebug-ide file being requested
Comment 3 Erno Mononen 2009-10-07 10:16:44 UTC
Looks like caused by a known RubyGems bug, namely http://rubyforge.org/tracker/index.php?
func=detail&aid=25935&group_id=126&atid=575. Pls see http://www.netbeans.org/issues/show_bug.cgi?id=171338#desc7 for 
more info.



*** This issue has been marked as a duplicate of 171338 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo