Bug 171338 - Impossible to create Rails project
Impossible to create Rails project
Status: RESOLVED WONTFIX
Product: ruby
Classification: Unclassified
Component: Project
6.x
Macintosh Mac OS X
: P2 with 1 vote (vote)
: 6.x
Assigned To: Erno Mononen
issues@ruby
: RELNOTE
: 173260 173917 174144 176125 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-02 17:03 UTC by miganb
Modified: 2010-05-25 15:14 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Creation of Rails project failing (284.29 KB, image/png)
2009-09-02 17:04 UTC, miganb
Details
Output window after creation (435 bytes, text/plain)
2009-09-02 17:05 UTC, miganb
Details
Log file after creation (45.82 KB, text/plain)
2009-09-02 17:07 UTC, miganb
Details
Project as it is created in Netbeans (9.04 KB, image/png)
2009-09-02 17:08 UTC, miganb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description miganb 2009-09-02 17:03:03 UTC
Mac OS X Leopard, Intel architecture
Netbeans version 6.8.m1

When trying to create a Rails project, I receive the following error (image attached).

Log attached.
Comment 1 miganb 2009-09-02 17:04:21 UTC
Created attachment 86986 [details]
Creation of Rails project failing
Comment 2 miganb 2009-09-02 17:05:52 UTC
Created attachment 86987 [details]
Output window after creation
Comment 3 miganb 2009-09-02 17:07:11 UTC
Created attachment 86988 [details]
Log file after creation
Comment 4 miganb 2009-09-02 17:08:09 UTC
Created attachment 86989 [details]
Project as it is created in Netbeans
Comment 5 Erno Mononen 2009-09-02 19:36:00 UTC
Thanks for the report. Seems rather serious, so I'm raising this to P2. I'll take a closer at this tomorrow.
Comment 6 Erno Mononen 2009-09-07 12:21:09 UTC
This turns out to be RubyGems issue ##25935 (http://rubyforge.org/tracker/index.php?
func=detail&aid=25935&group_id=126&atid=575), please RubyGems to 1.3.5. For the built-in JRuby you can do it as follows 
(from the command line):

<nb_install_dir>/ruby2/jruby-1.3.1/bin/jruby -S gem update --system

I'll see if we could bundle RubyGems 1.3.5 or newer in 6.8 FCS. possibly JRuby 1.4 (with newer rubygems) will be 
released in time for bundling it with NB 6.8.
Comment 7 miganb 2009-09-07 14:55:27 UTC
Thank you very much. It works by installing rubygems 1.3.5.
Comment 8 Erno Mononen 2009-09-29 13:06:41 UTC
*** Issue 173260 has been marked as a duplicate of this issue. ***
Comment 9 Erno Mononen 2009-09-29 13:17:24 UTC
*** Issue 173260 has been marked as a duplicate of this issue. ***
Comment 10 Tomas Danek 2009-09-29 14:27:50 UTC
should be documented for beta as a known issue.
Comment 11 Erno Mononen 2009-10-07 10:16:43 UTC
*** Issue 173917 has been marked as a duplicate of this issue. ***
Comment 12 Erno Mononen 2009-10-08 19:29:44 UTC
*** Issue 174144 has been marked as a duplicate of this issue. ***
Comment 13 Erno Mononen 2009-11-09 01:07:31 UTC
*** Bug 176125 has been marked as a duplicate of this bug. ***
Comment 14 Petr Jiricka 2010-05-25 12:08:52 UTC
Right now I can not get to the linked bug in RubyGems - here is a cached Google copy: http://webcache.googleusercontent.com/search?q=cache:-cJPo1rZv6MJ:rubyforge.org/tracker/index.php%3Ffunc%3Ddetail%26aid%3D25935%26group_id%3D126%26atid%3D575+rubyforge+25935&cd=1&hl=en&ct=clnk

Currently we bundle JRuby 1.5.0, which includes RubyGems 1.3.6, where this problem seems to be fixed, right? Can someone please confirm?

So I suspect this bug does not need to be mentioned in the release notes any more.
Comment 15 miganb 2010-05-25 15:14:17 UTC
(In reply to comment #14)
> Right now I can not get to the linked bug in RubyGems - here is a cached Google
> copy:
> http://webcache.googleusercontent.com/search?q=cache:-cJPo1rZv6MJ:rubyforge.org/tracker/index.php%3Ffunc%3Ddetail%26aid%3D25935%26group_id%3D126%26atid%3D575+rubyforge+25935&cd=1&hl=en&ct=clnk
> 
> Currently we bundle JRuby 1.5.0, which includes RubyGems 1.3.6, where this
> problem seems to be fixed, right? Can someone please confirm?
Yes, I confirm at least that JRuby 1.5.0 and RubyGems 1.3.6 works fine together. I have not tried inside NetBeans though.

Anyway, this is a very old bug (September 2009) reported on a beta version of NetBeans 6.8.

> 
> So I suspect this bug does not need to be mentioned in the release notes any
> more.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo