Bug 172620 - CopyResourcesOnSave.copySrcToDest missing synchronization
CopyResourcesOnSave.copySrcToDest missing synchronization
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Maven
6.x
All All
: P3 (vote)
: 7.0
Assigned To: Jesse Glick
issues@platform
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
: RANDOM, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-20 14:46 UTC by ecastro
Modified: 2010-10-07 03:13 UTC (History)
9 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.35 KB, text/plain)
2009-09-20 14:46 UTC, ecastro
Details
stacktrace (2.15 KB, text/plain)
2009-10-20 16:02 UTC, neilg
Details
stacktrace (1.98 KB, text/plain)
2010-01-11 03:30 UTC, Petr Jiricka
Details
stacktrace (2.00 KB, text/plain)
2010-04-28 10:17 UTC, big_al
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ecastro 2009-09-20 14:46:06 UTC
Build: NetBeans IDE Dev (Build nbms-and-javadoc-3939-on-090917)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Windows XP, 5.1, x86

User Comments:
ecastro: I first created a new JFrame in a maven project (with application framework) then I created a JButton

ecastro: Trying to create a FrameView for the JavaApplicationFramework

GUEST: Creating a properties file via the new file wizard.

The file was being placed into the folder  test/resources/properties within a standard layout maven project.



Stacktrace: 
java.lang.Throwable: Locked by:
        at org.openide.filesystems.FileLock.<init>(FileLock.java:80)
        at org.netbeans.modules.masterfs.filebasedfs.fileobjects.LockForFile.<init>(LockForFile.java:89)
        at org.netbeans.modules.masterfs.filebasedfs.fileobjects.LockForFile.tryLock(LockForFile.java:100)
        at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObj.lock(FileObj.java:313)
        at org.netbeans.modules.maven.cos.CopyResourcesOnSave.copySrcToDest(CopyResourcesOnSave.java:114)
        at org.netbeans.modules.maven.cos.CopyResourcesOnSave.handleCopyFileToDestDir(CopyResourcesOnSave.java:284)
Comment 1 ecastro 2009-09-20 14:46:12 UTC
Created attachment 87972 [details]
stacktrace
Comment 2 Exceptions Reporter 2009-09-20 14:46:17 UTC
This issue already has 6 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=155913
Comment 3 Jiri Skrivanek 2009-09-21 07:55:24 UTC
Please, suppress concurrent call of CopyResourcesOnSave.copySrcToDest.
Comment 4 neilg 2009-10-20 16:02:52 UTC
Build: NetBeans IDE Dev (Build 200910170201)
VM: Java HotSpot(TM) 64-Bit Server VM, 14.2-b01, Java(TM) SE Runtime Environment, 1.6.0_16-b01
OS: Linux, 2.6.28-15-generic, amd64

User Comments: 
Created new empty file

Stacktrace: 
java.lang.Throwable: Locked by:
        at org.openide.filesystems.FileLock.<init>(FileLock.java:80)
        at org.netbeans.modules.masterfs.filebasedfs.fileobjects.LockForFile.<init>(LockForFile.java:89)
        at org.netbeans.modules.masterfs.filebasedfs.fileobjects.LockForFile.tryLock(LockForFile.java:100)
        at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObj.lock(FileObj.java:308)
        at org.netbeans.modules.maven.cos.CopyResourcesOnSave.copySrcToDest(CopyResourcesOnSave.java:114)
        at org.netbeans.modules.maven.cos.CopyResourcesOnSave.handleCopyFileToDestDir(CopyResourcesOnSave.java:284)
Comment 5 neilg 2009-10-20 16:02:56 UTC
Created attachment 89778 [details]
stacktrace
Comment 6 Exceptions Reporter 2009-10-20 16:03:01 UTC
This issue already has 8 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=155913
Comment 7 Exceptions Reporter 2009-11-25 10:13:57 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=155913
Comment 8 Petr Jiricka 2010-01-11 03:30:05 UTC
Created attachment 93164 [details]
stacktrace

Creating file beans.xml from the "Empty file template in src/test/resources/META-INF
Comment 9 big_al 2010-04-28 10:17:18 UTC
Created attachment 98193 [details]
stacktrace

Created an empty file
Comment 10 Antonin Nebuzelsky 2010-07-30 15:17:30 UTC
Reassigning to default owner.
Comment 11 Jesse Glick 2010-10-06 17:23:13 UTC
Can't reproduce to verify fix, so just guessing: core-main #6f4aa52e1944
Comment 12 Quality Engineering 2010-10-07 03:13:44 UTC
Integrated into 'main-golden', will be available in build *201010070000* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/6f4aa52e1944
User: Jesse Glick <jglick@netbeans.org>
Log: #172620: unreproducible locking problem thought to be due to lack of synchronization.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo