Bug 169285 - livelock taking both CPUs while using EL :)
livelock taking both CPUs while using EL :)
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: JSP
6.x
Sun All
: P1 (vote)
: 6.x
Assigned To: Marek Fukala
issues@javaee
:
: 169347 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-28 08:00 UTC by Jindrich Sedek
Modified: 2009-11-25 05:26 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
full thread dump (21.93 KB, text/plain)
2009-07-28 08:01 UTC, Jindrich Sedek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jindrich Sedek 2009-07-28 08:00:34 UTC
open or create new JSP file
type '${' somewhere, cc appears, press BackSpace -> AWT gets blocked, both CPUs are running for 100%

quilty threads:
--------------------------
"Default RequestProcessor" daemon prio=3 tid=0x09a84000 nid=0x4f runnable [0xef5ff000..0xef5ffae0]
   java.lang.Thread.State: RUNNABLE
	at org.netbeans.modules.web.core.syntax.completion.ELExpression.parse(ELExpression.java:125)
	at org.netbeans.modules.web.jsf.editor.jspel.JSFELCompletionProvider$CCQuery.query
(JSFELCompletionProvider.java:99)
	at org.netbeans.spi.editor.completion.support.AsyncCompletionTask.run(AsyncCompletionTask.java:218)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:602)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1070)

"Default RequestProcessor" daemon prio=3 tid=0x092b6000 nid=0x4d runnable [0xee9ff000..0xee9ffbe0]
   java.lang.Thread.State: RUNNABLE
	at org.netbeans.modules.web.core.syntax.completion.ELExpression.parse(ELExpression.java:125)
	at org.netbeans.modules.web.core.syntax.completion.ElCompletionProvider$AbstractQuery.queryEL
(ElCompletionProvider.java:189)
	at org.netbeans.modules.web.core.syntax.completion.ElCompletionProvider$Query.doQuery
(ElCompletionProvider.java:108)
	at org.netbeans.modules.web.core.syntax.completion.ElCompletionProvider$AbstractQuery.query
(ElCompletionProvider.java:175)
	at org.netbeans.spi.editor.completion.support.AsyncCompletionTask.run(AsyncCompletionTask.java:218)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:602)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1070)
------------------
Comment 1 Jindrich Sedek 2009-07-28 08:01:13 UTC
Created attachment 85294 [details]
full thread dump
Comment 2 Marek Fukala 2009-07-28 08:25:06 UTC
fixed in web-main#566dbfc4f559
Comment 3 Jindrich Sedek 2009-07-28 15:06:52 UTC
*** Issue 169347 has been marked as a duplicate of this issue. ***
Comment 4 Quality Engineering 2009-07-28 17:47:53 UTC
Integrated into 'main-golden', will be available in build *200907281401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/566dbfc4f559
User: Marek Fukala <mfukala@netbeans.org>
Log: #169285 - livelock taking both CPUs while using EL  :)
Comment 5 Jindrich Sedek 2009-11-25 05:26:14 UTC
verified.
NetBeans IDE 6.8 RC1 (Build 200911241027)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo