Bug 168469 - JavaDesktop project can contain a missing library in FoD mode
JavaDesktop project can contain a missing library in FoD mode
Status: RESOLVED FIXED
Product: ide
Classification: Unclassified
Component: Features On Demand
6.x
PC Linux
: P3 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@performance
: ERGONOMICS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-13 11:16 UTC by matusdekanek
Modified: 2009-09-27 22:39 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
messages.log (24.53 KB, text/plain)
2009-07-13 11:20 UTC, matusdekanek
Details
screenshot: java not activated with open anagram project (225.56 KB, image/png)
2009-07-17 09:53 UTC, matusdekanek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description matusdekanek 2009-07-13 11:16:51 UTC
Product Version: NetBeans IDE Dev (Build 200907130200)
Java: 1.6.0_14-ea; Java HotSpot(TM) Client VM 14.0-b12
System: Linux version 2.6.28-13-generic running on i386; UTF-8; en_US (nb)

-have some java desktop application project on the disk
-start ide with clean userdir (therefore feature on demand is enabled, java support is disabled)
-open the java desktop application
The application is not compilable due to reference problems, because java is not enabled.
Creating a new java project solves this.
Comment 1 matusdekanek 2009-07-13 11:20:05 UTC
Created attachment 84643 [details]
messages.log
Comment 2 Milan Kubec 2009-07-14 09:23:24 UTC
I'm not able to reproduce the problem on current dev build, required java functionality is activated during project open.
Comment 3 matusdekanek 2009-07-15 09:16:30 UTC
I reproduced it on 
Product Version: NetBeans IDE Dev (Build 200907150249)
Java: 1.6.0_14-ea; Java HotSpot(TM) Client VM 14.0-b12
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)
Comment 4 matusdekanek 2009-07-15 09:37:16 UTC
So far only Desktop Application projects are affected. It seems like some information is missing in the Desktop 
Application project template. 
Reopening the issue. The priority may be lowered, because only one project template seems to be affected.
Comment 5 matusdekanek 2009-07-15 09:47:07 UTC
And it is not caused by feature on demand... the java is activated, but the project does not have correct settings of 
libraries (swing..). Please reassign.
Comment 6 Milan Kubec 2009-07-15 09:52:22 UTC
What is exactly the problem with libraries settings?
Comment 7 matusdekanek 2009-07-15 10:03:11 UTC
Reference problems. "One or more project resources could not be found".
Comment 8 matusdekanek 2009-07-15 10:17:02 UTC
NB 6.7.1 RC is not affected.
Comment 9 matusdekanek 2009-07-17 09:52:37 UTC
correction:
It seems that the 6.7.1 is affected as well (RC, Build 200907162301) and that IS caused by not-activated java (as it is
shown on the screenshot). 

Also the 'desktop application' template is not the only one affected, opening the anagram game project does not activate
java as well; that can be seen for example in project view where form files are shown in the project view as both .java
and .form files. (Opening some form file activates java).

Product Version: NetBeans IDE 6.7.1 RC (Build 200907162301)
Java: 1.6.0_14; Java HotSpot(TM) Client VM 14.0-b16
System: Linux version 2.6.28-13-generic running on i386; UTF-8; en_US (nb)
Comment 10 matusdekanek 2009-07-17 09:53:44 UTC
Created attachment 84878 [details]
screenshot: java not activated with open anagram project
Comment 11 Milan Kubec 2009-07-21 12:45:49 UTC
I've tried with AnagramGame project and with regular Desktop Application project and I'm still not able to reproduce.
Please try to *exactly* describe steps to reproduce starting with clean userdir. Thanks.
Comment 12 matusdekanek 2009-07-28 10:06:38 UTC
well, it is the same as I already described.
-have a java desktop application project and clean userdir
-install IDE (this step is not needed, the fresh userdir is important)
-start IDE and open the java desktop application project
java simply is not activated.
Comment 13 Milan Kubec 2009-07-28 10:11:58 UTC
Reassigning for evaluation, I'm not able to reproduce. Seems that part of modules is not activated.
Comment 14 Jaroslav Tulach 2009-08-07 15:18:54 UTC
Imho this works. You have following options:

1. show the problem to me next week
2. take snapshot of the "opened" project without Java activated (expand the content please)
3. attach messages.log when running with -J-Dorg.netbeans.modules.ide.ergonomics.level=ALL

Comment 15 Jaroslav Tulach 2009-08-07 15:31:16 UTC
I have found the screenshot, sorry. Looks like the Java is activated, but not fully. For example Form is probably 
disabled. I can see that you are running with javacard modules.

Warning - could not install some modules:
	org.netbeans.modules.javacard.ri.bundle - No module providing the capability org.openide.modules.os.Windows 
could be found.

These enable some java modules, but not form and as form registers swing-layout libraries, they cannot be found. Could 
be solved by moving the library definitions to java.kit module. Related to issue 162780, but the currently proposed 
fix for that issue will not be enough to solve this issue too.

Comment 16 Jaroslav Tulach 2009-09-21 08:41:36 UTC
ergonomics#88a6c71739c7
Comment 17 Quality Engineering 2009-09-27 22:39:18 UTC
Integrated into 'main-golden', will be available in build *200909270201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/88a6c71739c7
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #168469: Providing library definitions for all installed modules (even they are disabled). It should not be big problem, as the JARs are laying around, but who knows what it will break?


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo