Bug 168414 - ProjectUtils.getCacheDirectory
ProjectUtils.getCacheDirectory
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jesse Glick
issues@projects
: API, API_REVIEW_FAST
Depends on:
Blocks: 159642
  Show dependency treegraph
 
Reported: 2009-07-10 19:37 UTC by Jesse Glick
Modified: 2009-07-23 07:48 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Proposed patch (8.59 KB, patch)
2009-07-10 20:09 UTC, Jesse Glick
Details | Diff
Slightly revised patch (9.29 KB, patch)
2009-07-10 20:19 UTC, Jesse Glick
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2009-07-10 19:37:25 UTC
CacheDirectoryProvider is currently an SPI only. It would be nicer for clients to be able to call an API, which could
also provide a fallback value in case the project's lookup supplies no implementation. Compare the other get* methods in
ProjectUtils.
Comment 1 Jesse Glick 2009-07-10 20:09:19 UTC
Created attachment 84614 [details]
Proposed patch
Comment 2 Jesse Glick 2009-07-10 20:10:43 UTC
Please review.
Comment 3 Jesse Glick 2009-07-10 20:19:09 UTC
Created attachment 84615 [details]
Slightly revised patch
Comment 4 Milos Kleint 2009-07-13 07:34:37 UTC
looks ok. Why change the default location for ant projects?


Comment 5 Jesse Glick 2009-07-13 16:20:45 UTC
Calling your comment MK01, I decided to change the default location for Ant-based projects to something a bit simpler
(omit the /cache subdirectory) since the new API would anyway create a subdir for each interested module; the original
choice of dir name was intended to prevent clashes with private.properties or private.xml. No strong opinion about this
though.

I should mention that issue #159642 is the reason for wanting to do this change now.
Comment 6 Jesse Glick 2009-07-21 20:58:08 UTC
core-main #a09d4f52ed74
Comment 7 Quality Engineering 2009-07-23 07:48:09 UTC
Integrated into 'main-golden', will be available in build *200907230201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/a09d4f52ed74
User: Jesse Glick <jglick@netbeans.org>
Log: Issue #168414: provide API complement to CacheDirectoryProvider with fallback impl.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo