Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 168131 - No test results with Maven 2.2.0
No test results with Maven 2.2.0
Status: VERIFIED FIXED
Product: projects
Classification: Unclassified
Component: Maven
6.x
PC All
: P2 (vote)
: 6.x
Assigned To: Milos Kleint
issues@platform
67patch1-verified
:
: 168326 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-05 03:02 UTC by fuege
Modified: 2009-07-20 13:46 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fuege 2009-07-05 03:02:13 UTC
Using NB 6.7 with Maven 2.2.0 (JUnit) "Test Results" are *not* shown.
Even the second tab on the standard "Output" window is missing (the one that shows links to sources on failure, for
example).

Env. var. M2_HOME is set, so that "Tools|Options|Misc.|Maven" says 'Default Maven version X.x is found on path'.

That configuration works well with Maven 2.1.0!
Setting the Maven home path explicitly doesn't help.
Comment 1 Milos Kleint 2009-07-07 13:12:26 UTC
it's not only test related, compilation errors don't show up underlined either, none of the output parsers work as the
output format has changed in 2.2.0
Comment 2 Milos Kleint 2009-07-07 14:19:07 UTC
fixed by adapting the regexp parsing to accept the new build section format introduced in 2.2.0 as well.
http://hg.netbeans.org/main/rev/484ff2403764
Comment 3 Quality Engineering 2009-07-08 05:37:05 UTC
Integrated into 'main-golden', will be available in build *200907080200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/484ff2403764
User: Milos Kleint <mkleint@netbeans.org>
Log: #168131 the output pattern for start of plugin goal processing hs changed in 2.2.0, we need to adapt the regexp parsing
Comment 4 Jaroslav Pospisil 2009-07-08 12:50:17 UTC
v.
Comment 5 pgebauer 2009-07-08 16:00:39 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/2d65b7a9d37a
Comment 6 Milos Kleint 2009-07-09 11:46:27 UTC
*** Issue 168326 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo