Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 166910 - @LookupMerger.Registration does not work on >1 project
@LookupMerger.Registration does not work on >1 project
Status: VERIFIED FIXED
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Jesse Glick
issues@projects
67patch1-verified
:
Depends on:
Blocks: 150194 166575
  Show dependency treegraph
 
Reported: 2009-06-11 11:57 UTC by Marian Mirilovic
Modified: 2009-07-16 17:32 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Mirilovic 2009-06-11 11:57:15 UTC
better fix for issue 166575
Comment 1 Jesse Glick 2009-06-11 18:34:17 UTC
Not sure what the problem was. Tests pass AFAIK but perhaps only affects a bigger system?
Comment 2 Milos Kleint 2009-06-11 19:05:14 UTC
my suspicion is that it could be related to the order of items being looked up from the project.

i'm still inclined to just delete the annotation and related code rather than attempt to fix code I don't understand..
Comment 3 Jesse Glick 2009-06-11 21:52:33 UTC
It's a public API, it cannot simply be deleted. If you don't want to fix it, reassign it.
Comment 4 Milos Kleint 2009-06-12 07:18:04 UTC
fine
Comment 5 Jesse Glick 2009-06-12 16:06:58 UTC
Seems to be reproducible:

1. hg up 71c179e30950
2. ant rebuild-cluster -Drebuild.cluster.name=nb.cluster.groovy
3. http://www.netbeans.org/nonav/issues/show_bug.cgi?id=166575#desc9
Comment 6 Jesse Glick 2009-06-12 18:35:23 UTC
The issue arises when there is more than one project using the same kind of lookup merger, and all have their lookups
initialized before the mergeable class is first queried: for example, when two j2seproject's are opened and then you
right-click each in turn. The mergeable class was being injected into the lookup of the first project to be queried only.

core-main #383e75d2b624 and this is pullable directly into release67 if desired (parented to changeset of #150194 impl).
Since others might wish to use @LM.R in 6.7 I recommend this be merged either into an RC or into a patch update.
Comment 7 Quality Engineering 2009-06-13 06:54:27 UTC
Integrated into 'main-golden', will be available in build *200906130201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/383e75d2b624
User: Jesse Glick <jglick@netbeans.org>
Log: #166910: @LookupMerger.Registration does not work on >1 project.
Comment 8 Marian Mirilovic 2009-07-03 11:20:05 UTC
verified
Comment 9 pgebauer 2009-07-07 10:54:01 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/de006ac54ba2


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo