Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 166835 - Regression: OpenLocalExplorerAction opens empty explorer view
Regression: OpenLocalExplorerAction opens empty explorer view
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Explorer
6.x
PC Linux
: P3 (vote)
: 6.x
Assigned To: Jesse Glick
issues@platform
67patch1-fixed
: REGRESSION
: 165816 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 09:18 UTC by tschlegl
Modified: 2009-07-09 15:43 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tschlegl 2009-06-10 09:18:29 UTC
Hitting the "Explore From Here" context menu item on an explorer folder node which has the
OpenLocalExplorerAction set opens a empty and title-less explorer view.
This can easily be reproduced and tested with the feedreader application - just add
SystemAction.get(OpenLocalExplorerAction.class) to the actions of RssNode.java.
I found this bug on 6.7beta first, it's working on 6.7m3.
Comment 1 t_h 2009-06-11 13:47:37 UTC
broken by b9fe471ed13f. Jesse, why ExplorerTab was replaced just by empty ExplorerPanel?
Comment 2 Jesse Glick 2009-06-11 18:14:59 UTC
I can fix it. Didn't realize anyone was actually using OpenLocalExplorerAction anywhere; was never well supported (does
not work well with NB 3.6+ window system).
Comment 3 Jesse Glick 2009-06-11 18:50:54 UTC
core-main #cff09f3c3eeb
Comment 4 Quality Engineering 2009-06-12 09:20:12 UTC
Integrated into 'main-golden', will be available in build *200906120201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/cff09f3c3eeb
User: Jesse Glick <jglick@netbeans.org>
Log: #166835: fixing OpenLocalExplorerAction.
Comment 5 t_h 2009-06-12 11:51:27 UTC
Unnecessary horiz. scrollbar was shown. Fixed in core-main #78117a776a79
Comment 6 t_h 2009-06-12 11:52:32 UTC
*** Issue 165816 has been marked as a duplicate of this issue. ***
Comment 7 Jesse Glick 2009-06-12 15:03:48 UTC
Should the same refinement be applied to openide.explorer/src/org/netbeans/modules/openide/explorer/NodeOperationImpl.java?
Comment 8 t_h 2009-06-12 17:04:38 UTC
yes, I did it in core-main #1432166eb34e
Comment 9 Petr Blaha 2009-07-03 09:18:03 UTC
tschlegl can you verify the issue in the trunk? Thanks
Comment 10 martin_zmrhal 2009-07-07 13:59:12 UTC
Verified in 200907070200
Comment 11 pgebauer 2009-07-09 15:10:28 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/d1ab2287d52c
Comment 12 Jesse Glick 2009-07-09 15:43:59 UTC
I think 78117a776a79 and 1432166eb34e should be backported as well.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo