Bug 166460 - correct inline javascript is marked as an error
correct inline javascript is marked as an error
Status: VERIFIED FIXED
Product: web
Classification: Unclassified
Component: HTML Editor
6.x
Sun All
: P1 (vote)
: 6.x
Assigned To: Marek Fukala
Jindrich Sedek
:
: 166359 166547 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-03 10:15 UTC by Jindrich Sedek
Modified: 2009-06-04 13:32 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jindrich Sedek 2009-06-03 10:15:51 UTC
use this code in HTML file:
------------------
<div onkeydown="test()"></div>
------------------
javascript error appears
Comment 1 Marek Fukala 2009-06-03 10:19:08 UTC
fixed in web-main#8afa0b1bc1d3

incorrect assertion usage - embedding are incorrectly created w/o assertions enabled, see the diff

confirming this is a stopper issue, please verify in trunk with disabled assertions!
Comment 2 Jindrich Sedek 2009-06-03 10:44:19 UTC
verified in web-main repository

the fix is trivial and ok - code reviewed

please transplant to 6.7 clone
Comment 3 Marek Fukala 2009-06-03 11:45:05 UTC
transplanted to release67 clone
Comment 4 Jindrich Sedek 2009-06-04 08:51:08 UTC
verified in rc2 build
NetBeans IDE 6.7 RC2 (Build 200906040112)
Comment 5 Martin Schovanek 2009-06-04 11:05:17 UTC
*** Issue 166359 has been marked as a duplicate of this issue. ***
Comment 6 Jindrich Sedek 2009-06-04 13:32:16 UTC
*** Issue 166547 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo