Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 166142 - JUnit's Go To Source menu item doesn't work in Maven projects
JUnit's Go To Source menu item doesn't work in Maven projects
Status: RESOLVED WORKSFORME
Product: projects
Classification: Unclassified
Component: Maven
6.x
Sun All
: P3 (vote)
: 6.x
Assigned To: David Simonek
issues@platform
: RANDOM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-28 00:55 UTC by rdelaplante
Modified: 2009-09-18 13:07 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rdelaplante 2009-05-28 00:55:39 UTC
In NetBeans 6.7 the Maven support switched to the common test runner.  When I right click on failed tests or on their
stack dump there is a Go To Source menu item.  When I click it, nothing happens.  This is a badly needed feature, please
fix it before release.
Comment 1 Andrey Yamkovoy 2009-05-28 07:16:28 UTC
The actions for the nodes are configured on the Maven side. Not a JUnit issue.
Reassign to maven for evaluation.
Comment 2 Milos Kleint 2009-05-28 12:35:07 UTC
same comment as in 166144, with the sample project I'm able to use the feature both with build invoked by maven and by
ant (via Compile On Save).

reassigning to dsimonek for deeper evaluation, could be platform dependent, in any case we would need some sample
project and detailed steps to reproduce.
Comment 3 rdelaplante 2009-06-11 14:46:54 UTC
In the JUnit test results window I right click the test class that had a failure, select go to source, and it opens the
test class with the cursor at the very top.  Next I try right clicking the failed test and clicking go to source
expecting it to take me to the method in the test class that failed.  When I click Go To Source my computer beeps at me
and nothing happens. 

My projects cannot be shared since they are closed source and private for a customer. Sorry
Comment 4 rdelaplante 2009-06-11 14:53:21 UTC
I tried this on a tiny project with just one test class and one test in it.  When I right click the failed test and
select Go To Source, it opens the test class and puts the cursor at the method that failed. This is what I expect.  The
project where this doesn't work has many test classes and hundreds of tests.
Comment 5 David Simonek 2009-07-24 14:52:18 UTC
Works for me OK on sample project that I assigned to 166144. Please try to provide some sample project on which this
issue is reproducible, otherwise I will not be able to do anything but close this report, thanks.
Comment 6 Marian Mirilovic 2009-09-18 13:07:10 UTC
Without requested information for long time - WORKSFORME. We can't do anything in this case. Reporter, please add
requested information and reopen issue. Thanks in advance.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo