Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 165936 - NullPointerException at org.netbeans.modules.maven.customizer.AddPropertyDialog$Loader.run
NullPointerException at org.netbeans.modules.maven.customizer.AddPropertyDial...
Status: VERIFIED FIXED
Product: projects
Classification: Unclassified
Component: Maven
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Milos Kleint
issues@platform
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT 67patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-25 11:27 UTC by Oleg Khokhlov
Modified: 2009-07-15 12:15 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (305 bytes, text/plain)
2009-05-25 11:27 UTC, Oleg Khokhlov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oleg Khokhlov 2009-05-25 11:27:02 UTC
This issue was originally marked as duplicate of issue 162742, that is already resolved. This issue is still valid, so this seems to be another issue, but it might be related.

Build: NetBeans IDE Dev (Build 200905190201)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Windows XP, 5.1, x86

User Comments:
ovk: Options->Misc->Maven->Edit Global Custom Goal Definitions
- Add action;
- Add Plugin Expression Property;



Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.maven.customizer.AddPropertyDialog$Loader.run(AddPropertyDialog.java:227)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:576)
        at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1013)
Comment 1 Oleg Khokhlov 2009-05-25 11:27:11 UTC
Created attachment 82726 [details]
stacktrace
Comment 2 Milos Kleint 2009-06-04 13:45:43 UTC
http://hg.netbeans.org/main/rev/d1d30248f0c4

can you share the value in the goals field when the exception occurs?
Comment 3 Oleg Khokhlov 2009-06-04 13:54:01 UTC
 "Execute Goals" and "Activate profiles" fields are empty
Comment 4 Quality Engineering 2009-06-11 08:43:24 UTC
Integrated into 'main-golden', will be available in build *200906110201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/d1d30248f0c4
User: Milos Kleint <mkleint@netbeans.org>
Log: #165936 project field can be null when not invoked from a project context
Comment 5 Jaroslav Pospisil 2009-06-25 15:49:39 UTC
v
Comment 6 pgebauer 2009-07-02 12:33:54 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/1224d5be652b
Comment 7 Oleg Khokhlov 2009-07-15 12:15:22 UTC
v. in 6.7.1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo