Bug 165262 - [67cat] Deadlock between SourceCache and CurrentRequestReference
[67cat] Deadlock between SourceCache and CurrentRequestReference
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Parsing & Indexing
6.x
PC Windows XP
: P2 (vote)
: 6.x
Assigned To: Tomas Zezula
issues@editor
: RANDOM, THREAD
: 165268 165438 165492 165515 165518 166052 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-15 11:56 UTC by dynamite
Modified: 2009-05-27 10:55 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
thread dump retrieved using the Visual VM 1.1.1 (19.37 KB, text/plain)
2009-05-15 11:58 UTC, dynamite
Details
No code synchronizes on Source anymore (1.13 KB, text/plain)
2009-05-15 21:38 UTC, Vitezslav Stejskal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dynamite 2009-05-15 11:56:54 UTC
I was editing a JUnit 4.5 test case.  It removed (expected=NullPointerException.class) as a selected block from an @Test
annotation.  I then selected and tried to change some text within that method and got this exception.  I should note
that I had not long ago renamed the JUnit test class.
Comment 1 dynamite 2009-05-15 11:58:45 UTC
Created attachment 82182 [details]
thread dump retrieved using the Visual VM 1.1.1
Comment 2 dynamite 2009-05-15 11:59:56 UTC
Product Version: NetBeans IDE Dev (Build 200905141401)
Java: 1.6.0_11; Java HotSpot(TM) Client VM 11.0-b16
System: Windows XP version 5.1 running on x86; Cp1252; en_GB (nb)
Comment 3 David Strupl 2009-05-15 20:32:26 UTC
*** Issue 165268 has been marked as a duplicate of this issue. ***
Comment 4 Vitezslav Stejskal 2009-05-15 21:36:26 UTC
I assume this can't be reliably reproduced. It looks like the assert statements in CRR.setCurrenTask somehow slipped
through Tomas' fingers when he was unifying the threading model. And now after fixing issue #164258
(http://hg.netbeans.org/jet-main/rev/823cff42a0da) there are two different locks (CRR_LOCK and INTERNAL_LOCK) being
locked in opposite order. Anyway, IMO the fix is simple and I'm going to attach a patch. Tomasi please review and
possibly apply. Thanks
Comment 5 Vitezslav Stejskal 2009-05-15 21:38:13 UTC
Created attachment 82228 [details]
No code synchronizes on Source anymore
Comment 6 Tomas Zezula 2009-05-18 11:08:41 UTC
Fixed jet-main 92ac77d0dafd
Comment 7 Quality Engineering 2009-05-19 07:19:10 UTC
Integrated into 'main-golden', will be available in build *200905190201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/92ac77d0dafd
User: Tomas Zezula <tzezula@netbeans.org>
Log: #165262:[67cat] Deadlock between SourceCache and CurrentRequestReference
Comment 8 Jan Pokorsky 2009-05-19 15:40:30 UTC
*** Issue 165492 has been marked as a duplicate of this issue. ***
Comment 9 Jan Jancura 2009-05-20 08:56:06 UTC
*** Issue 165518 has been marked as a duplicate of this issue. ***
Comment 10 Vitezslav Stejskal 2009-05-20 12:23:40 UTC
*** Issue 165515 has been marked as a duplicate of this issue. ***
Comment 11 Jan Jancura 2009-05-21 11:36:25 UTC
*** Issue 165438 has been marked as a duplicate of this issue. ***
Comment 12 Vitezslav Stejskal 2009-05-27 10:55:46 UTC
*** Issue 166052 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo