Bug 163001 - [67cat] java.net.URISyntaxException: Illegal character in path at index 105: (Space character is at index 105)
[67cat] java.net.URISyntaxException: Illegal character in path at index 105: ...
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Parsing & Indexing
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Rastislav Komara
issues@editor
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
: SPACE_IN_PATH
Depends on: 163185
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-18 11:14 UTC by neilg
Modified: 2009-04-23 10:17 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.96 KB, text/plain)
2009-04-18 11:14 UTC, neilg
Details
stacktrace (3.50 KB, text/plain)
2009-04-18 19:27 UTC, abajja
Details
stacktrace (3.61 KB, text/plain)
2009-04-20 12:20 UTC, Andrei Chistiakov
Details
stacktrace (3.63 KB, text/plain)
2009-04-20 16:10 UTC, Ivan Sidorkin
Details
stacktrace (3.83 KB, text/plain)
2009-04-20 23:47 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description neilg 2009-04-18 11:14:22 UTC
Build: NetBeans IDE Dev (Build 200904161401)
VM: Java HotSpot(TM) Client VM, 10.0-b19, Java(TM) SE Runtime Environment, 1.6.0_05-b13
OS: Windows Vista, 6.0, x86

User Comments:
mjreged: Opened the IDE, Started to scan maven projects



Stacktrace: 
java.io.IOException: java.net.URISyntaxException: Illegal character in path at index 105: file:/E:/development/ft/web-functional-tests/web-staging/src/test/resources/testdata/methode/images/64x64 image.jpg
        at org.netbeans.modules.java.source.tasklist.TaskCache.refreshTransaction(TaskCache.java:472)
        at org.netbeans.modules.java.source.tasklist.TaskCache.dumpErrors(TaskCache.java:194)
        at org.netbeans.modules.java.source.indexing.JavaCustomIndexer$2$1.run(JavaCustomIndexer.java:197)
        at org.netbeans.modules.java.source.indexing.JavaCustomIndexer$2$1.run(JavaCustomIndexer.java:188)
        at org.netbeans.modules.java.source.tasklist.TaskCache.refreshTransaction(TaskCache.java:468)
        at org.netbeans.modules.java.source.indexing.JavaCustomIndexer$2.run(JavaCustomIndexer.java:188)
Comment 1 neilg 2009-04-18 11:14:34 UTC
Created attachment 80406 [details]
stacktrace
Comment 2 abajja 2009-04-18 19:26:59 UTC
Build: NetBeans IDE Dev (Build 200904171401)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Windows Vista, 6.0, x86

User Comments: 
Persist

Stacktrace: 
java.io.IOException: java.net.URISyntaxException: Illegal character in path at index 65: file:/C:/projects/maga-yii-m/protected/controllers/SiteController - copia.php
        at org.netbeans.modules.java.source.tasklist.TaskCache.refreshTransaction(TaskCache.java:472)
        at org.netbeans.modules.java.source.tasklist.TaskCache.dumpErrors(TaskCache.java:194)
        at org.netbeans.modules.java.source.indexing.JavaCustomIndexer$2$1.run(JavaCustomIndexer.java:197)
        at org.netbeans.modules.java.source.indexing.JavaCustomIndexer$2$1.run(JavaCustomIndexer.java:188)
        at org.netbeans.modules.java.source.tasklist.TaskCache.refreshTransaction(TaskCache.java:468)
        at org.netbeans.modules.java.source.indexing.JavaCustomIndexer$2.run(JavaCustomIndexer.java:188)
Comment 3 abajja 2009-04-18 19:27:09 UTC
Created attachment 80417 [details]
stacktrace
Comment 4 Andrei Chistiakov 2009-04-20 12:19:51 UTC
Build: NetBeans IDE 6.7 Beta (Build 200904192254)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b02
OS: Windows XP, 5.1, x86

User Comments: 
- add a new Java class into JavaApplication;
- delete the class

Stacktrace: 
java.io.IOException: java.net.URISyntaxException: Illegal character in path at index 18: file:/C:/Documents and Settings/cay/My Documents/NetBeansProjects/JavaApplication1/src/javaapplication1/NewClass.java
        at org.netbeans.modules.java.source.tasklist.TaskCache.refreshTransaction(TaskCache.java:472)
        at org.netbeans.modules.java.source.tasklist.TaskCache.dumpErrors(TaskCache.java:194)
        at org.netbeans.modules.java.source.indexing.JavaCustomIndexer$2$1.run(JavaCustomIndexer.java:197)
        at org.netbeans.modules.java.source.indexing.JavaCustomIndexer$2$1.run(JavaCustomIndexer.java:188)
        at org.netbeans.modules.java.source.tasklist.TaskCache.refreshTransaction(TaskCache.java:468)
        at org.netbeans.modules.java.source.indexing.JavaCustomIndexer$2.run(JavaCustomIndexer.java:188)
Comment 5 Andrei Chistiakov 2009-04-20 12:20:04 UTC
Created attachment 80508 [details]
stacktrace
Comment 6 Ivan Sidorkin 2009-04-20 15:20:57 UTC
too easy to reproduce
should it be upgraded to P2 or P1?
will be good to have fix for beta
Comment 7 Ivan Sidorkin 2009-04-20 16:09:54 UTC
Build: NetBeans IDE 6.7 Beta (Build 200904192254)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b02
OS: Windows XP, 5.1, x86

User Comments: 


Stacktrace: 
java.io.IOException: java.net.URISyntaxException: Illegal character in path at index 18: file:/C:/Documents and Settings/is153249/My Documents/NetBeansProjects/JavaApplication8/src/javaapplication8/NewClass.java
        at org.netbeans.modules.java.source.tasklist.TaskCache.refreshTransaction(TaskCache.java:472)
        at org.netbeans.modules.java.source.tasklist.TaskCache.dumpErrors(TaskCache.java:194)
        at org.netbeans.modules.java.source.indexing.JavaCustomIndexer$2$1.run(JavaCustomIndexer.java:197)
        at org.netbeans.modules.java.source.indexing.JavaCustomIndexer$2$1.run(JavaCustomIndexer.java:188)
        at org.netbeans.modules.java.source.tasklist.TaskCache.refreshTransaction(TaskCache.java:468)
        at org.netbeans.modules.java.source.indexing.JavaCustomIndexer$2.run(JavaCustomIndexer.java:188)
Comment 8 Ivan Sidorkin 2009-04-20 16:10:03 UTC
Created attachment 80526 [details]
stacktrace
Comment 9 Ivan Sidorkin 2009-04-20 16:19:11 UTC
deleting Main.java from just created JavaApplication will cause this exception
Comment 10 Exceptions Reporter 2009-04-20 23:46:59 UTC
Build: NetBeans IDE Dev (Build 200904171401)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Windows XP, 5.1, x86

User Comments: 


Stacktrace: 
java.io.IOException: java.net.URISyntaxException: Illegal character in path at index 11: file:/D:/My Documents/NetBeansProjects/KPAngkasaPura2/src/report1.jasper
        at org.netbeans.modules.java.source.tasklist.TaskCache.refreshTransaction(TaskCache.java:472)
        at org.netbeans.modules.java.source.tasklist.TaskCache.dumpErrors(TaskCache.java:194)
        at org.netbeans.modules.java.source.indexing.JavaCustomIndexer$2$1.run(JavaCustomIndexer.java:197)
        at org.netbeans.modules.java.source.indexing.JavaCustomIndexer$2$1.run(JavaCustomIndexer.java:188)
        at org.netbeans.modules.java.source.tasklist.TaskCache.refreshTransaction(TaskCache.java:468)
        at org.netbeans.modules.java.source.indexing.JavaCustomIndexer$2.run(JavaCustomIndexer.java:188)
Comment 11 Exceptions Reporter 2009-04-20 23:47:05 UTC
Created attachment 80551 [details]
stacktrace
Comment 12 Rastislav Komara 2009-04-21 08:44:09 UTC
I rise this issue to P2. And set target milestone to 6.7
Comment 13 Ivan Sidorkin 2009-04-21 09:03:55 UTC
will you fix it in Beta?
it is regression to M3 so priority can be changed to P1
Comment 14 Rastislav Komara 2009-04-21 09:16:40 UTC
@ivansidorki: I raised priority by 1 (to P2) because of regression. There is only 6 duplicates. I will not provide fix
for Beta until QE makes this showstopper for Beta. 

@mmirilovic: Is this issue stopper from QE point of view?
Comment 15 Marian Mirilovic 2009-04-21 09:43:05 UTC
@moonko: I would vote for a fix into Beta, could you prepare a fix ? Thanks in advance.
Comment 16 Rastislav Komara 2009-04-21 10:19:33 UTC
We discussed this issue with vstejskal. He take care of this.
Comment 17 David Strupl 2009-04-21 10:29:40 UTC
moonko: So you disscussed with Vita and assigned it to Hanz? I am assigning to Vita then.
Comment 18 Rastislav Komara 2009-04-21 10:30:46 UTC
I try introduce some workaround for this issue first.
Comment 19 Marian Mirilovic 2009-04-21 10:47:39 UTC
@moonko: proposed fix for similar issues by phejl http://www.netbeans.org/issues/show_bug.cgi?id=161053#desc6
Comment 20 Rastislav Komara 2009-04-21 11:13:32 UTC
Fixed in jet-main #3aab1a7dd5de
Comment 21 Vitezslav Stejskal 2009-04-21 12:53:18 UTC
IMO this is the same regression caused by issue #162907 and so in fact a duplicate of issue #163185.
Comment 22 Quality Engineering 2009-04-22 08:44:27 UTC
Integrated into 'main-golden', will be available in build *200904220201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/3aab1a7dd5de
User: Rastislav Komara <moonko@netbeans.org>
Log: Workaround fix for issue #163001: [67cat] java.net.URISyntaxException: Illegal character in path at index 105: (Space character is at index 105)
Comment 23 Jiri Prox 2009-04-22 10:01:35 UTC
verified in trunk
Comment 24 Vitezslav Stejskal 2009-04-22 13:08:57 UTC
Transplanted to release67_beta as http://hg.netbeans.org/release67_beta/rev/15a98e6c71dc.
Comment 25 Jiri Prox 2009-04-23 10:17:16 UTC
verified in 6.7beta


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo