Bug 163185 - IllegalArgumentException: fileURL may not contain spaces!
IllegalArgumentException: fileURL may not contain spaces!
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Parsing & Indexing
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Vitezslav Stejskal
issues@editor
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
: REGRESSION, SPACE_IN_PATH
: 161053 163181 163196 163203 163241 163261 163306 163319 (view as bug list)
Depends on:
Blocks: 163001
  Show dependency treegraph
 
Reported: 2009-04-21 08:07 UTC by Ivan Sidorkin
Modified: 2009-04-23 17:20 UTC (History)
9 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.02 KB, text/plain)
2009-04-21 08:07 UTC, Ivan Sidorkin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Sidorkin 2009-04-21 08:07:00 UTC
Build: NetBeans IDE 6.7 Beta (Build 200904192254)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b02
OS: Windows XP, 5.1, x86

User Comments:
masaki: I'm using internal build for 6.7 beta.

1. create a PHP project
2. type "print" then ctrl+space



Stacktrace: 
org.netbeans.modules.parsing.spi.ParseException
        at org.netbeans.modules.parsing.impl.TaskProcessor.runUserTask(TaskProcessor.java:191)
        at org.netbeans.modules.parsing.api.ParserManager.parse(ParserManager.java:99)
        at org.netbeans.modules.csl.editor.completion.GsfCompletionProvider$JavaCompletionQuery.query(GsfCompletionProvider.java:319)
        at org.netbeans.spi.editor.completion.support.AsyncCompletionTask.run(AsyncCompletionTask.java:218)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:573)
        at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1005)
Comment 1 Ivan Sidorkin 2009-04-21 08:07:07 UTC
Created attachment 80563 [details]
stacktrace
Comment 2 Tomasz Slota 2009-04-21 09:10:53 UTC
I cannot reproduce it for now.

What was the directory path of your project? What was the path of NB user directory? What OS were you using? A full IDE log could help as well.
Comment 3 Ivan Sidorkin 2009-04-21 09:38:00 UTC
just open URL with statistics
you will have all information you need
Comment 4 Tomasz Slota 2009-04-21 09:50:35 UTC
*** Issue 163203 has been marked as a duplicate of this issue. ***
Comment 5 Exceptions Reporter 2009-04-21 10:59:54 UTC
This issue already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=149803
Comment 6 Tomasz Slota 2009-04-21 11:06:40 UTC
OK, I can reproduce with on Windows with the current dev build
Comment 7 Filip Zamboj 2009-04-21 11:23:47 UTC
this is considered 6.7beta stopper 
Comment 8 Vitezslav Stejskal 2009-04-21 12:25:00 UTC
It's in indexing infra. I'll have look.
Comment 9 Vitezslav Stejskal 2009-04-21 12:39:56 UTC
*** Issue 161053 has been marked as a duplicate of this issue. ***
Comment 10 Vitezslav Stejskal 2009-04-21 12:41:14 UTC
*** Issue 163196 has been marked as a duplicate of this issue. ***
Comment 11 Vitezslav Stejskal 2009-04-21 12:50:32 UTC
This regression was in fact introduced when fixing issue #162907. It's now fixed by
http://hg.netbeans.org/jet-main/rev/0019d97262fd. Could somebody please retest scenarios in this issue and all its
duplicates (ideally on Windows or at least with having spaces in your project path, which is what I did to verify the
fix on my laptop)? I'll then transplant the fix to release67_beta. Thanks
Comment 12 Jiri Prox 2009-04-21 14:52:34 UTC
verified in trunk, please transplate the fix in beta branch
Comment 13 Vitezslav Stejskal 2009-04-21 15:20:08 UTC
Transplanted to release67_beta as http://hg.netbeans.org/release67_beta/rev/91c5a291351c
Comment 14 Tomasz Slota 2009-04-21 16:35:24 UTC
*** Issue 163241 has been marked as a duplicate of this issue. ***
Comment 15 Vitezslav Stejskal 2009-04-21 17:02:42 UTC
*** Issue 163261 has been marked as a duplicate of this issue. ***
Comment 16 Marian Mirilovic 2009-04-21 17:06:44 UTC
*** Issue 163181 has been marked as a duplicate of this issue. ***
Comment 17 Quality Engineering 2009-04-22 08:41:43 UTC
Integrated into 'main-golden', will be available in build *200904220201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/0019d97262fd
User: Vita Stejskal <vstejskal@netbeans.org>
Log: #163185 - generate encoded URLs
Comment 18 Tomasz Slota 2009-04-22 10:27:07 UTC
*** Issue 163306 has been marked as a duplicate of this issue. ***
Comment 19 Tomasz Slota 2009-04-22 13:26:33 UTC
*** Issue 163319 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo