Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 162819 - Two different "Plugins" dialogs
Two different "Plugins" dialogs
Status: CLOSED DUPLICATE of bug 163411
Product: platform
Classification: Unclassified
Component: Plugin Manager
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@platform
:
Depends on:
Blocks: 162673
  Show dependency treegraph
 
Reported: 2009-04-16 12:11 UTC by Marian Mirilovic
Modified: 2009-05-10 22:41 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Mirilovic 2009-04-16 12:11:30 UTC
NB Dev (20090416)

We have two different Plugins dialogs after implementing issue 162673 :
1. Tools | Plugins
... with Advanced View = on
2. Activate Features
... with Advanced View = off

Ondro, I would say the whole dialog is "not consistent" but now I would say it's even worse ... user is able to open the
same dialog from two different places and she'll face two different contents
Comment 1 Ondrej Langr 2009-04-16 17:58:14 UTC
Why me? :-)

I agree ... The main purpose of having coarse module granularity is so that users can turn functionality easily on/off,
and the modules should be exposed in equal granularity no matter how the dialog is invoked. As for whether this option
should be persistent, I have no strong opinion about it but I tend to say no for a simple reason - I don't expect the
dialog to be accessed in a common memory span for such data. Which means every time the dialog would be invoked, it
would be displayed in "simple" view. 

Any objections, thoughts? 

I guess this is for Jarda ... correct me if I'm wrong ... 
Comment 2 Jaroslav Tulach 2009-04-16 18:16:41 UTC
"user is able to open the same dialog" - that is quite common all over the IDE. New File vs. popup/New opens the same 
dialog with different initial set up. Also the welcome screen opens different tab than Tools/Plugins. Is this no 
inconsistency to complain about? Probably not.

I am surprised that two completely different gestures leading to dialog with different tab selected and preset 
selected is considered P2 bug.

In my opinion different granularity makes a lot of sense. While the "welcome screen" entry point is for newcomers to 
set up their system, the Tools/Plugin entry point is for expert users. Obviously the later shall see advanced mode.

But this is my last and only argument.
Comment 3 Marian Mirilovic 2009-04-28 07:49:12 UTC
As has been discussed on Friday Apr 17, 2009 we need to change Plugin manager in following way:

> * no matter how the dialog will be accessed, simple view will be shown by default
Comment 4 Jaroslav Tulach 2009-04-29 10:04:52 UTC
This bug will be fixed as soon as outstanding issue, like 163411 are solved. If for some reason the outstanding issues 
are found unfixable, or new problems are found, the consistency is going to be sacrificed in the name of correctness. 
Agreed in:


>> Conclusions:
>>
>> * no matter how the dialog will be accessed, simple view will be shown by
>> default
>
> I understood, that if the following conditions are successfully resolved (and 
> everyone decided to help with that and dedicate necessary time), then the 
> above will happen.

And Ondřej agreed.


Comment 5 Jaroslav Tulach 2009-05-05 20:19:10 UTC
Will be fixed as soon as patch
http://www.netbeans.org/nonav/issues/showattachment.cgi/81538/162820.diff
attached to issue 163411 is applied.

*** This issue has been marked as a duplicate of 163411 ***
Comment 6 Marian Mirilovic 2009-05-10 22:41:34 UTC
v/c


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo