Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 163411 - Activate button + simple/advanced switch must have more natural place
Activate button + simple/advanced switch must have more natural place
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Plugin Manager
6.x
All All
: P2 (vote)
: 6.x
Assigned To: dlipin
issues@platform
:
: 162819 162850 163646 (view as bug list)
Depends on:
Blocks: 162673
  Show dependency treegraph
 
Reported: 2009-04-22 16:02 UTC by Jaroslav Tulach
Modified: 2009-05-07 07:57 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Activate/Deactivate/Uninstall support checkbox multiselection and are at bottom of the dialog (19.00 KB, patch)
2009-04-23 16:06 UTC, Jaroslav Tulach
Details | Diff
advanced view switch (102.90 KB, image/png)
2009-05-02 20:18 UTC, Ondrej Langr
Details
suggested solution fro 6.7 (116.00 KB, image/png)
2009-05-05 12:27 UTC, Ondrej Langr
Details
proposed patch due to the UI Ondrej suggested (29.37 KB, patch)
2009-05-05 13:17 UTC, dlipin
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Tulach 2009-04-22 16:02:37 UTC
As has been discussed on Friday Apr 17, 2009 we need to change Plugin manager in following way:

> * activate button will be replaced by Activate/Deactivate buttons on the
> left right, in the same area as the disable button. Column of checkboxes
> will be renamed to "Select" and both buttons will work upon selection in
> this column (the list should not allow multiselection, then)
>
> * Ondra will suggest different location (and possibly also form) of the
> simple/advanced switch by the end of the next week.

Dmitry is it OK if I prepare a patch (like the one I sent on Friday, plus support for multiselection) and then let you 
deal with this issue?
Comment 1 Marian Mirilovic 2009-04-22 16:49:13 UTC
*** Issue 162850 has been marked as a duplicate of this issue. ***
Comment 2 dlipin 2009-04-23 11:35:48 UTC
yes, please go ahead.
Comment 3 Jaroslav Tulach 2009-04-23 16:06:32 UTC
Created attachment 80782 [details]
Activate/Deactivate/Uninstall support checkbox multiselection and are at bottom of the dialog
Comment 4 Jaroslav Tulach 2009-04-27 09:46:34 UTC
*** Issue 163646 has been marked as a duplicate of this issue. ***
Comment 5 Jaroslav Tulach 2009-04-29 10:06:59 UTC
Ondřeji, did you find better UI representation for the "Advanced Mode" switcher? We need your advice to more further 
with issue 162819.
Comment 6 dlipin 2009-04-29 14:35:30 UTC
I`d played with it a little bit an it looks fine for me (no issues). Thanks!
Comment 7 Ondrej Langr 2009-05-02 20:16:53 UTC
Jarda, Tonda, I apologize for the delay. I played with it and I came with 4 alternatives out of which I most liked the
one which is similar to the current one, only with different location of the checkbox and also a different name. 5th
alternative could be two tabs, but that doesn't very well work for same data - different views and also contradicts most
guidelines (tabs in tabs).

Let me explain why I think this is the best one:

1) Visually, it seems there is only one view on list of plugins (no switch, which would put an equal weight on both
views). Majority of our users should only need the large granularity list, and it is there available for them at the
first sight. For those who will struggle to find what they are looking for (and/or will want to disable a particular
plugin), the checkbox is at easy-to-spot location and should be the obvious way to continue if user is stuck and d

2) Location-wise, if solves the original problem (reported somewhere) that the switch should be visually bound to list
of plugins.

3) Language-wise, we have been talking a lot about simple/advanced view, but when trying to see this from users' eyes, a
use-case they would want to see the "advanced view" in is when they are looking for a particular pack and can not find
it. In this context, they want to see the content of individual bundles - details of individual bundles. Therefore "show
details".

What do you think? 
Comment 8 Ondrej Langr 2009-05-02 20:18:58 UTC
Created attachment 81415 [details]
advanced view switch
Comment 9 dlipin 2009-05-04 08:59:01 UTC
BTW, the left (list of plugins) and right (plugin info) panels are separated by a splitter.
In other words, user can make one panel be wide and the other one be narrow. 
The "show details" checkbox should be always at the middle (by X axis), right?
Comment 10 Tomas Pavek 2009-05-04 14:54:50 UTC
"Show details" can't be aligned with the splitter - it's very problematic to implement and would IMHO look strange when
the user drag the splitter. Another issue with this is that in reality the checkbox would be quite close to the
Uninstall, Activate and Deactivate buttons (BTW the Deactivate button is missing on the picture). It might look like
related to the buttons. Is that intended?
Comment 11 Ondrej Langr 2009-05-05 12:26:41 UTC
After long and heated argument :-), we've found a solution that is acceptable by both parties. It makes clear the simple
view is main and expected, yet puts the switch into a prominent (a little nudge ... maybe too prominent? ;-) ) position.

A drawback from my point of view is that two IMO least used elements are put to the upper left corner, but it is the
only acceptable solution we can implement for 6.7.
Comment 12 Ondrej Langr 2009-05-05 12:27:39 UTC
Created attachment 81533 [details]
suggested solution fro 6.7
Comment 13 dlipin 2009-05-05 13:15:46 UTC
The new patch is attached, I`ll wait for its integration till Thursday evening so that everyone interested (Jarda?:) 
reviews it.

BTW, it also makes a better fix for 162820 and fixes 163355.
Comment 14 dlipin 2009-05-05 13:18:32 UTC
Created attachment 81538 [details]
proposed patch due to the UI Ondrej suggested
Comment 15 Jaroslav Tulach 2009-05-05 13:57:49 UTC
The patch seems to be OK. It works and it follows the new UI spec.

I can have only one minor "architectural" comment. The "InitialTab" and "plugin.manager.detail.view.selected" 
properties shall be documented as exported API in autoupdate.ui/arch.xml (if it existed) or 
autoudate.services/arch.xml. Their stability does not need to be high friend (as welcome screen uses that) and private 
(as it is only for advanced end users).

Otherwise I am looking forward to see this patch integrated.
Comment 16 Jaroslav Tulach 2009-05-05 20:19:02 UTC
*** Issue 162819 has been marked as a duplicate of this issue. ***
Comment 17 dlipin 2009-05-06 12:00:45 UTC
Fixed (arch.xml has been also updated), thanks Jarda for the initial patch and further reviews.
http://hg.netbeans.org/core-main/rev/603db44af84e
Comment 18 Quality Engineering 2009-05-07 07:57:35 UTC
Integrated into 'main-golden', will be available in build *200905070201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/603db44af84e
User: Dmitry Lipin <dlipin@netbeans.org>
Log: Issue #163411 Activate button + simple/advanced switch must have more natural place


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo