Bug 162800 - IllegalArgumentException: Called DataObject.find on null
IllegalArgumentException: Called DataObject.find on null
Status: RESOLVED DUPLICATE of bug 160239
Product: ide
Classification: Unclassified
Component: Features On Demand
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@performance
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
: ERGONOMICS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-16 10:24 UTC by Petr Suchomel
Modified: 2009-06-21 13:43 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (5.72 KB, text/plain)
2009-04-16 10:25 UTC, Petr Suchomel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Suchomel 2009-04-16 10:24:47 UTC
Build: NetBeans IDE Dev (Build 090409)
VM: Java HotSpot(TM) Client VM, 1.5.0_15-b04, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_15-b04
OS: Windows XP, 5.1, x86

User Comments:
psuchomel: Adding Java platform - after opening the Java Platform dialog



Stacktrace: 
java.lang.IllegalArgumentException: Called DataObject.find on null
        at org.openide.loaders.DataObject.find(DataObject.java:481)
        at org.netbeans.modules.java.platform.ui.PlatformsCustomizer.addNewPlatform(PlatformsCustomizer.java:326)
        at org.netbeans.modules.java.platform.ui.PlatformsCustomizer.access$000(PlatformsCustomizer.java:88)
        at org.netbeans.modules.java.platform.ui.PlatformsCustomizer$1.actionPerformed(PlatformsCustomizer.java:196)
        at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1849)
        at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2169)
Comment 1 Petr Suchomel 2009-04-16 10:25:01 UTC
Created attachment 80224 [details]
stacktrace
Comment 2 _ tboudreau 2009-04-16 19:59:22 UTC
Changing priority to P2.  AFACT, if you start NetBeans with the ergonomics cluster enabled, this action will cause an
exception 100% of the time.
Comment 3 David Strupl 2009-04-17 12:41:58 UTC
Do I understand it correctly that this does not happen without ergonomics?
Comment 4 Jan Jancura 2009-04-20 12:19:06 UTC
Not reproducible for me. My usecase:
1) install latest full ide dev build (form netbeans.org!!!)
2) start netbeans
> there is no Java Platforms in the Tools menu.
So, can you attach some reproducible usecase, please?
Comment 5 _ tboudreau 2009-04-21 05:21:20 UTC
I suspect the difference is that I am running NetBeans with the Java Card modules installed.  They implement a Java
project and Java Platform.  Perhaps they trigger some partial enablement of the Java modules?

The module is currently on an internal SVN server - I can probably get you access if you need it.
Comment 6 _ tboudreau 2009-04-21 05:47:08 UTC
And yes, this does not happen w/o ergonomics
Comment 7 Vitezslav Stejskal 2009-05-06 17:03:39 UTC
Templates/Services/Platforms/org-netbeans-api-java-Platform/javaplatform.xml does not exist on SystemFileSystem. It's in
the module layer in the same module as org.netbeans.modules.java.platform.ui.PlatformsCustomizer. So, something really
strange happened....
Comment 8 David Strupl 2009-05-06 20:42:04 UTC
I guess this one is a duplicate of 160239 which was fixed some time ago.

*** This issue has been marked as a duplicate of 160239 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo