Bug 162415 - java.util.ConcurrentModificationException at org.openide.util.WeakSet$WeakSetIterator.checkModcount
java.util.ConcurrentModificationException at org.openide.util.WeakSet$WeakSet...
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Generic Projects UI
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Andrey Yamkovoy
issues@projects
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
: RANDOM, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-10 16:11 UTC by martinhavle
Modified: 2009-04-15 19:31 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (581 bytes, text/plain)
2009-04-10 16:11 UTC, martinhavle
Details
Proposed fix (2.26 KB, patch)
2009-04-13 07:19 UTC, Andrey Yamkovoy
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description martinhavle 2009-04-10 16:11:13 UTC
Build: NetBeans IDE Dev (Build 200904100201)
VM: Java HotSpot(TM) Client VM, 14.0-b12, Java(TM) SE Runtime Environment, 1.6.0_14-ea-b03
OS: SunOS, 5.11, x86

User Comments:
martinhavle: Just started IDE.



Stacktrace: 
java.util.ConcurrentModificationException
        at org.openide.util.WeakSet$WeakSetIterator.checkModcount(WeakSet.java:481)
        at org.openide.util.WeakSet$WeakSetIterator.hasNext(WeakSet.java:432)
        at org.netbeans.modules.project.ui.ProjectsRootNode.checkNoLazyNode(ProjectsRootNode.java:205)
        at org.netbeans.modules.project.ui.OpenProjectList$LoadOpenProjects.run(OpenProjectList.java:318)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:573)
        at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1005)
Comment 1 martinhavle 2009-04-10 16:11:27 UTC
Created attachment 79904 [details]
stacktrace
Comment 2 Andrey Yamkovoy 2009-04-13 06:46:37 UTC
Actually this issue not reproducible for me but anyway the static set should be synchronized.
Comment 3 Andrey Yamkovoy 2009-04-13 07:19:39 UTC
Created attachment 79959 [details]
Proposed fix
Comment 4 Jesse Glick 2009-04-14 15:09:21 UTC
If you always access it using 'synchronized (all)' then using Collections.synchronizedSet is superfluous. (Generally I
find Collections.synchronized* not very useful because you so often want to do more than one operation at a time to the
collection.)
Comment 5 Andrey Yamkovoy 2009-04-15 06:52:26 UTC
I will remove Collections.synchronizedSet from the patch.
Comment 6 Andrey Yamkovoy 2009-04-15 07:43:27 UTC
Fixed in the core-main
Comment 7 Quality Engineering 2009-04-15 19:31:30 UTC
Integrated into 'main-golden', will be available in build *200904151401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/2b1d0560aa74
User: Andrey Yamkovoy <kaktus@netbeans.org>
Log: Fix for issue #162415 - java.util.ConcurrentModificationException at org.openide.util.WeakSet$WeakSetIterator.checkModcount


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo