Bug 161053 - IllegalArgumentException: Malformed escape pair at index 120: file:/Library/Ruby/Gems/1.8/gems/merb_activerecord-1.0.0.1/lib/generators/templates/session_migration/schema/migrations/%version%_database
IllegalArgumentException: Malformed escape pair at index 120: file:/Library/R...
Status: RESOLVED DUPLICATE of bug 163185
Product: java
Classification: Unclassified
Component: Source
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Rastislav Komara
issues@java
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
: SPACE_IN_PATH
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-24 17:14 UTC by bobocopy
Modified: 2009-04-21 12:40 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.59 KB, text/plain)
2009-03-24 17:15 UTC, bobocopy
Details
stacktrace (4.78 KB, text/plain)
2009-03-26 15:32 UTC, jbwiv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bobocopy 2009-03-24 17:14:56 UTC
Build: NetBeans IDE Dev (Build 200903221401)
VM: Java HotSpot(TM) Client VM, 1.5.0_16-133, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_16-b06-284
OS: Mac OS X, 10.5.6, i386

User Comments:
bobocopy: Regular ol' Ruby editing.



Stacktrace: 
java.lang.IllegalArgumentException: Malformed escape pair at index 120: file:/Library/Ruby/Gems/1.8/gems/merb_activerecord-1.0.0.1/lib/generators/templates/session_migration/schema/migrations/%version%_database_sessions.rb [file:/Library/Ruby/Gems/1.8/gems/merb_activerecord-1.0.0.1/lib/generators/templates/session_migration/schema/migrations/%version%_database_sessions.rb]
        at org.netbeans.modules.masterfs.filebasedfs.FileBasedURLMapper.getFileObjects(FileBasedURLMapper.java:122)
        at org.netbeans.modules.masterfs.MasterURLMapper.getFileObjects(MasterURLMapper.java:62)
        at org.openide.filesystems.URLMapper.findFileObject(URLMapper.java:213)
        at org.netbeans.modules.parsing.spi.indexing.support.IndexResult.getFile(IndexResult.java:111)
        at org.netbeans.modules.ruby.RubyIndex.createMethod(RubyIndex.java:593)
        at org.netbeans.modules.ruby.RubyIndex.getMethods(RubyIndex.java:519)
Comment 1 bobocopy 2009-03-24 17:15:10 UTC
Created attachment 78772 [details]
stacktrace
Comment 2 Jiri Skrivanek 2009-03-25 08:51:51 UTC
Wrong URL is returned from IndexResult.getFile(). Use file.toURI().toURL() to create correct URL.
Comment 3 jbwiv 2009-03-26 15:32:10 UTC
Build: NetBeans IDE Dev (Build 200903250219)
VM: Java HotSpot(TM) Client VM, 11.2-b01, Java(TM) SE Runtime Environment, 1.6.0_12-b04
OS: Linux, 2.6.27-11-generic, i386

User Comments: 
Opening an existing ruby project. Although, from the error, I'm betting this came from NB's ruby scan.		

Stacktrace: 
java.lang.IllegalArgumentException: Illegal character in path at index 74: file:/usr/lib/ruby/gems/1.8/gems/rubyzip-0.9.1/lib/quiz1/t/solutions/James Edward Gray II/solitaire.rb [file:/usr/lib/ruby/gems/1.8/gems/rubyzip-0.9.1/lib/quiz1/t/solutions/James Edward Gray II/solitaire.rb]
        at org.netbeans.modules.masterfs.filebasedfs.FileBasedURLMapper.getFileObjects(FileBasedURLMapper.java:122)
        at org.netbeans.modules.masterfs.MasterURLMapper.getFileObjects(MasterURLMapper.java:62)
        at org.openide.filesystems.URLMapper.findFileObject(URLMapper.java:213)
        at org.netbeans.modules.parsing.spi.indexing.support.IndexResult.getFile(IndexResult.java:111)
        at org.netbeans.modules.ruby.RubyIndex.createMethod(RubyIndex.java:593)
        at org.netbeans.modules.ruby.RubyIndex.addMethodsFromClass(RubyIndex.java:1038)
Comment 4 jbwiv 2009-03-26 15:32:27 UTC
Created attachment 78916 [details]
stacktrace
Comment 5 Petr Hejl 2009-04-20 12:11:40 UTC
diff -r 7058fe2363fc parsing.api/src/org/netbeans/modules/parsing/impl/indexing/Util.java
--- a/parsing.api/src/org/netbeans/modules/parsing/impl/indexing/Util.java Mon Apr 20 12:44:59 2009 +0200
+++ b/parsing.api/src/org/netbeans/modules/parsing/impl/indexing/Util.java Mon Apr 20 13:05:27 2009 +0200
@@ -128,7 +128,7 @@
public static URL resolveUrl(URL root, String relativePath) throws MalformedURLException {
try {
if ("file".equals(root.getProtocol())) { //NOI18N
- return new File(new File(root.toURI()), relativePath).toURL();
+ return new File(new File(root.toURI()), relativePath).toURI().toURL();
} else {
return root.toURI().resolve(relativePath).toURL();
}
Comment 6 Ivan Sidorkin 2009-04-20 15:59:32 UTC
Product Version: NetBeans IDE 6.7 Beta (Build 200904192254)
Java: 1.6.0_13; Java HotSpot(TM) Client VM 11.3-b02
System: Windows XP version 5.1 running on x86; Cp1251; ru_RU (nb)

- create Java Application
- create PHP project

got message :"; might be because your user directory is on a Windows UNC path (issue #46813)? If so, try using mapped
drive letters."

and exception in log:

Caused: java.lang.IllegalArgumentException: Illegal character in path at index 18: file:/C:/Documents and
Settings/is153249/My Documents/NetBeansProjects/JavaApplication4/src/javaapplication4/Main.java [file:/C:/Documents and
Settings/is153249/My Documents/NetBeansProjects/JavaApplication4/src/javaapplication4/Main.java]
[catch] at org.netbeans.modules.masterfs.filebasedfs.FileBasedURLMapper.getFileObjects(FileBasedURLMapper.java:122)
	at org.netbeans.modules.masterfs.MasterURLMapper.getFileObjects(MasterURLMapper.java:62)
	at org.openide.filesystems.URLMapper.findFileObject(URLMapper.java:213)
	at org.netbeans.modules.parsing.spi.indexing.support.IndexResult.getFile(IndexResult.java:112)
	at org.netbeans.modules.tasklist.impl.Loader.loadTasks(Loader.java:127)
	at org.netbeans.modules.tasklist.impl.Loader.run(Loader.java:89)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:573)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1005)
ALL [null]: ; might be because your user directory is on a Windows UNC path (issue #46813)? If so, try using mapped
drive letters.
Comment 7 Marian Mirilovic 2009-04-21 10:38:28 UTC
related to issue 163001 ?
Comment 8 Rastislav Komara 2009-04-21 11:38:37 UTC
I don't think so.
Comment 9 Vitezslav Stejskal 2009-04-21 12:40:12 UTC
The same as issue #163185.

*** This issue has been marked as a duplicate of 163185 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo