Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 159060 - Invalid "missing ) after argument list" warning
Invalid "missing ) after argument list" warning
Status: RESOLVED FIXED
Product: javascript
Classification: Unclassified
Component: Editor
6.x
All All
: P3 (vote)
: TBD
Assigned To: Marek Fukala
issues@javascript
http://www.stpe.se/wp-content/uploads...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-24 14:10 UTC by stefpet
Modified: 2009-02-27 14:26 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stefpet 2009-02-24 14:10:39 UTC
Error reproduced on following system:
 Product Version: NetBeans IDE 6.5 (Build 200811100001)
 Java: 1.6.0_06; Java HotSpot(TM) Client VM 10.0-b22
 System: Windows XP version 5.1 running on x86; Cp1252; sv_SE (nb)
 Userdir: C:\Documents and Settings\stpe\.netbeans\6.5

When writing JavaScript code the warning "missing ) after argument list" is displayed incorrectly. By triggering a
re-evaluation of the file (by inserting a space somewhere) it goes away.

Steps to reproduce:

Open an empty file named test.js (for example).

Write the following code:

function foo() {
    new Hello(bar, baz);
}

All should be fine. Now remove the space, or insert an additional space, between to two variables. Any change at that
position seem to trigger the error:

function foo() {
    new Hello(bar,baz);
}

Note "missing ) after argument list" warning. The warning will go away once the file is "re-evaluated" (i.e. simply
enter any character (like a space) anywhere in the file.

Doing exactly the same but outside a function will not trigger the error.

Please see screenshot linked to in the URL field for visual explanation.
Comment 1 stefpet 2009-02-27 07:38:01 UTC
I'm not able to reproduce this issue in 6.7 M2 (Build 200902231810).
Comment 2 Martin Schovanek 2009-02-27 10:41:19 UTC
Already fixed in trunk builds.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo