Bug 158223 - By Default GF V3 Prelude should appear at Server List for All version
By Default GF V3 Prelude should appear at Server List for All version
Status: RESOLVED WONTFIX
Product: ide
Classification: Unclassified
Component: Features On Demand
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@performance
: ERGONOMICS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-09 19:36 UTC by davisn
Modified: 2009-06-21 13:43 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description davisn 2009-02-09 19:36:33 UTC
-After launching the Netbean IDE 7.0Dev, none of the Glassfish Server plugins appear under the Server List Node even I
was using the All features version
-This bug is about usability and compatibility (with 6.5)

Build used: Netbean IDE Dev 200902080201
Comment 1 Vince Kraemer 2009-02-09 21:04:26 UTC
Do any servers appear in the list? v2 or Tomcat?
Comment 2 davisn 2009-02-09 22:30:06 UTC
None appears in the list
Comment 3 Vince Kraemer 2009-02-11 00:41:12 UTC
I think this is 'by design'...

I will let somebody else explain why this is considered to be OK.
Comment 4 Jaroslav Tulach 2009-02-11 20:29:57 UTC
I guess I need more steps to reproduce. What I did:
1. get the full ide
2. start it.
3. look at services tab
4. there is no Servers node => OK.
5. open some existing ruby project
6. look at services tab again
7. servers node is there
8. Add Server is enabled. Glassfish V3 is there.

If this is what you see, then it is expected behaviour. Can you tell me why it represents a problem?
If you see something else, please add more detailed steps to reproduce. Thanks.
Comment 5 davisn 2009-02-11 22:56:44 UTC
-The problem is that for using All IDE version I already plan my projects to run with Web & Java EE Servers plugins.
So why I need to apply one extra step to activate the Servers that I plan to use at the first place. Why they are not
appeared under Servers node by default just like what we have from NB 6.5? 

-If I don't want those servers I won't download the Java or All version at the first place.
This is my observation as a user. 
Comment 6 davisn 2009-02-11 22:58:12 UTC
-The problem is that for using All IDE version I already plan my projects to run with Web & Java EE Servers plugins.
So why I need to apply one extra step to activate the Servers that I plan to use at the first place. Why they are not
appeared under Servers node by default just like what we have from NB 6.5? 

-If I don't want those servers I won't download the Java or All version at the first place.
This is my observation as a user. 
Comment 7 Jaroslav Tulach 2009-02-12 08:25:46 UTC
At beginning, the Servers node is not visible. Not everyone needs that functionality, however just tell the IDE that 
you want it, for example by opening your favorite web project, and the node will be shown. And it will contain all the 
installed servers, will it not?


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo