Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 156695 - AssertionError at com.sun.tools.javac.comp.Attr.attribClassBody
AssertionError at com.sun.tools.javac.comp.Attr.attribClassBody
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Compiler
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Dusan Balek
issues@java
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
: 155559 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-13 15:56 UTC by Jiri Prox
Modified: 2009-02-19 21:09 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.90 KB, text/plain)
2009-01-13 15:57 UTC, Jiri Prox
Details
stacktrace (2.70 KB, text/plain)
2009-01-26 09:56 UTC, rgarske
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Prox 2009-01-13 15:56:52 UTC
Build: NetBeans IDE Dev (Build 20090113073351)
VM: Java HotSpot(TM) Client VM, 11.0-b16, Java(TM) SE Runtime Environment, 1.6.0_11-b03
OS: Linux, 2.6.24-23-generic, i386

User Comments:
jiriprox: AE when editing code

GUEST: Debugging.  Writing an assignment from an ArrayList.

jiriprox: AE when editing code



Stacktrace: 
java.lang.AssertionError
        at com.sun.tools.javac.comp.Attr.attribClassBody(Attr.java:2780)
        at com.sun.tools.javac.comp.Attr.attribClass(Attr.java:2719)
        at com.sun.tools.javac.comp.Attr.attribClass(Attr.java:2650)
        at com.sun.tools.javac.main.JavaCompiler.attribute(JavaCompiler.java:1076)
        at com.sun.tools.javac.api.JavacTaskImpl$2.process(JavacTaskImpl.java:450)
        at com.sun.tools.javac.api.JavacTaskImpl$Filter.run(JavacTaskImpl.java:598)
Comment 1 Jiri Prox 2009-01-13 15:57:00 UTC
Created attachment 75767 [details]
stacktrace
Comment 2 Jiri Prox 2009-01-13 15:59:23 UTC
Steps (unfortunately not reproducible)
1) have a code:
/*
 * To change this template, choose Tools | Templates
 * and open the template in the editor.
 */

package javaapplication59;

import com.google.common.collect.HashBiMap;

/**
 *
 * @author jp159440
 */
public class Main {

		static com.google.common.collect.HashBiMap biMap = new HashBiMap();
    /**
     * @param args the command line arguments
     */
    public static void main(String[] args) {
        biMap.
        Test t;
    }

}

2) use CC to complete method get from biMap class
3) delete code inserted by CC to get to original state
Comment 3 Dusan Balek 2009-01-15 15:56:42 UTC
Fixed.

changeset c958ac2f6935 in main/nb-javac
details: http://hg.netbeans.org/main/nb-javac?cmd=changeset;node=c958ac2f6935
changeset 2a6f27ff1bed in main
details: http://hg.netbeans.org/main?cmd=changeset;node=2a6f27ff1bed
Comment 4 Quality Engineering 2009-01-16 07:21:08 UTC
Integrated into 'main-golden', will be available in build *200901160201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/2a6f27ff1bed
User: Dusan Balek <dbalek@netbeans.org>
Log: Issues #118035 and #156695 fixed.
Comment 5 rgarske 2009-01-26 09:56:52 UTC
Build: NetBeans IDE Dev (Build 200901140201)
VM: Java HotSpot(TM) Server VM, 11.0-b16, Java(TM) SE Runtime Environment, 1.6.0_11-b03
OS: Windows XP, 5.1, x86

User Comments: 
exception occoured while I was typing in the Editor.

Stacktrace: 
java.lang.AssertionError
        at com.sun.tools.javac.comp.Attr.attribClassBody(Attr.java:2780)
        at com.sun.tools.javac.comp.Attr.attribClass(Attr.java:2719)
        at com.sun.tools.javac.comp.Attr.attribClass(Attr.java:2650)
        at com.sun.tools.javac.main.JavaCompiler.attribute(JavaCompiler.java:1076)
        at com.sun.tools.javac.api.JavacTaskImpl$2.process(JavacTaskImpl.java:450)
        at com.sun.tools.javac.api.JavacTaskImpl$Filter.run(JavacTaskImpl.java:598)
Comment 6 rgarske 2009-01-26 09:56:56 UTC
Created attachment 76227 [details]
stacktrace
Comment 7 Dusan Balek 2009-01-29 17:29:43 UTC
*** Issue 155559 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo