Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 155559 - AssertionError while go to source operation in memory profiling
AssertionError while go to source operation in memory profiling
Status: RESOLVED DUPLICATE of bug 156695
Product: java
Classification: Unclassified
Component: Source
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Dusan Balek
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-16 14:26 UTC by Rashid Urusov
Modified: 2009-02-19 21:09 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rashid Urusov 2008-12-16 14:26:43 UTC
Product Version: NetBeans IDE Dev (Build 200812150750)
Java: 1.6.0_07; Java HotSpot(TM) Client VM 10.0-b23
System: Windows XP version 5.1 running on x86; Cp1251; ru_RU (nb)
Userdir: C:\Documents and Settings\user\.netbeans\dev

Steps to reproduce:
-Start to memory profiling of AnagramGame with default settings
-Go to Live Results
-Invoke from context menu Go to source item for java.util.Hashtable$Entry

I've got following :

java.lang.AssertionError
	at com.sun.tools.javac.comp.Attr.attribClassBody(Attr.java:2780)
	at com.sun.tools.javac.comp.Attr.attribClass(Attr.java:2719)
	at com.sun.tools.javac.comp.Attr.attribClass(Attr.java:2650)
	at com.sun.tools.javac.main.JavaCompiler.attribute(JavaCompiler.java:1076)
	at com.sun.tools.javac.api.JavacTaskImpl$2.process(JavacTaskImpl.java:450)
	at com.sun.tools.javac.api.JavacTaskImpl$Filter.run(JavacTaskImpl.java:598)
	at com.sun.tools.javac.api.JavacTaskImpl.analyze(JavacTaskImpl.java:453)
	at org.netbeans.modules.java.source.TreeLoader.loadTreeFor(TreeLoader.java:143)
	at com.sun.tools.javac.code.Symbol$ParamSymbol.getSimpleName(Symbol.java:1045)
	at com.sun.tools.javac.code.Symbol$ParamSymbol.getSimpleName(Symbol.java:1012)
	at
org.netbeans.modules.java.editor.overridden.ElementDescription$ElementNameVisitor.visitVariable(ElementDescription.java:150)
	at
org.netbeans.modules.java.editor.overridden.ElementDescription$ElementNameVisitor.visitVariable(ElementDescription.java:107)
	at com.sun.tools.javac.code.Symbol$VarSymbol.accept(Symbol.java:932)
	at
org.netbeans.modules.java.editor.overridden.ElementDescription$ElementNameVisitor.visitExecutable(ElementDescription.java:140)
	at
org.netbeans.modules.java.editor.overridden.ElementDescription$ElementNameVisitor.visitExecutable(ElementDescription.java:107)
	at com.sun.tools.javac.code.Symbol$MethodSymbol.accept(Symbol.java:1340)
	at org.netbeans.modules.java.editor.overridden.ElementDescription.<init>(ElementDescription.java:80)
	at
org.netbeans.modules.java.editor.overridden.IsOverriddenAnnotationHandler.process(IsOverriddenAnnotationHandler.java:306)
	at org.netbeans.modules.java.editor.overridden.IsOverriddenAnnotationHandler.run(IsOverriddenAnnotationHandler.java:130)
	at org.netbeans.modules.java.editor.overridden.IsOverriddenAnnotationHandler.run(IsOverriddenAnnotationHandler.java:103)
	at org.netbeans.modules.java.source.JavaSourceAccessor$CancelableTaskWrapper.run(JavaSourceAccessor.java:288)
	at org.netbeans.modules.parsing.impl.TaskProcessor$CompilationJob.run(TaskProcessor.java:683)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
[catch] at java.lang.Thread.run(Thread.java:619)
Comment 1 Dusan Balek 2009-01-29 17:29:51 UTC
Already fixed.

*** This issue has been marked as a duplicate of 156695 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo