Bug 154756 - IDE hangs on opening C++ project
IDE hangs on opening C++ project
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Code
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Martin Entlicher
issues@debugger
: ERGONOMICS
: 155701 155813 156272 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 14:33 UTC by Alexander Pepin
Modified: 2009-06-20 08:44 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
messages.log (30.23 KB, text/plain)
2008-12-05 14:34 UTC, Alexander Pepin
Details
messages.log (200.95 KB, text/plain)
2008-12-05 15:56 UTC, Alexander Pepin
Details
screenshot (136.22 KB, image/jpeg)
2008-12-05 15:57 UTC, Alexander Pepin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Pepin 2008-12-05 14:33:46 UTC
Steps to reproduce:
- run IDE with a fresh userdir
- try to open existing C++ project (precreated Quote sample project)
Result: IDE hangs. Progress bar in right bottom corner freezes showing "Activating Java Profiler".
Comment 1 Alexander Pepin 2008-12-05 14:34:43 UTC
Created attachment 74610 [details]
messages.log
Comment 2 Pavel Flaska 2008-12-05 15:20:30 UTC
I cannot reproduce. My steps:
i) run ide, create Quote sample project,
ii) close the project, exit IDE,
iii) delete user dir,
iv) run the ide, open project Quote,
v) c++ cluster was activated.

Profiler and java are still disabled. Maybe I do it wrong.
Comment 3 Alexander Pepin 2008-12-05 15:39:43 UTC
What platform do you use?
I tested on Windows Vista with installed cygwin and MinGW.
I used the same scenario as you did.
Comment 4 Alexander Pepin 2008-12-05 15:51:42 UTC
I forgot,
 I created Quote project, then I debugged it (set breakpoints etc.) and of course I opened files in the editor but this
should not affect the following process as I removed userdir.
Comment 5 Alexander Pepin 2008-12-05 15:52:59 UTC
I tried once again and moved one step further.
Screenshot and log will be attached.
Comment 6 Alexander Pepin 2008-12-05 15:56:15 UTC
Created attachment 74621 [details]
messages.log
Comment 7 Alexander Pepin 2008-12-05 15:57:01 UTC
Created attachment 74622 [details]
screenshot
Comment 8 Jaroslav Tulach 2008-12-07 12:18:32 UTC
If the problem is in the following exception, then Martin shall fix that in debugger:

Caused: java.util.ConcurrentModificationException
	at org.netbeans.api.debugger.LazyArrayList$Itr.next(LazyArrayList.java:213)
	at org.netbeans.api.debugger.ActionsManager.initActionImpls(ActionsManager.java:431)
	at org.netbeans.api.debugger.ActionsManager.isEnabled(ActionsManager.java:264)
	at org.netbeans.modules.debugger.ui.actions.DebuggerAction.isEnabled(DebuggerAction.java:123)
	at org.netbeans.modules.debugger.ui.actions.DebuggerAction.<init>(DebuggerAction.java:78)
	at org.netbeans.modules.debugger.ui.actions.DebuggerAction.createKillAction(DebuggerAction.java:163)
Comment 9 Pavel Flaska 2008-12-08 14:38:15 UTC
Unfortunately one of the fix from Thursday was not part of tested build. Should be ok in current builds.

Changeset 110559.

Please verify and reopen if it occur in current builds.

Comment 10 ahot 2008-12-16 12:04:52 UTC
OK in Build 200812150750
Comment 11 Peter Pis 2008-12-19 08:38:25 UTC
*** Issue 155701 has been marked as a duplicate of this issue. ***
Comment 12 Peter Pis 2008-12-19 08:43:38 UTC
*** Issue 155813 has been marked as a duplicate of this issue. ***
Comment 13 Exceptions Reporter 2009-01-22 10:19:22 UTC
Reopening - reproduced in NetBeans IDE Dev (Build 090121)
http://statistics.netbeans.org/exceptions/detail.do?id=139402
Comment 14 Martin Entlicher 2009-01-22 10:45:22 UTC
Will fix into M2.
Comment 15 Martin Entlicher 2009-01-22 10:45:42 UTC
*** Issue 156272 has been marked as a duplicate of this issue. ***
Comment 16 Martin Entlicher 2009-02-04 15:36:32 UTC
Fixed in changeset:   116268:3dab3ccdddf8
http://hg.netbeans.org/main/rev/3dab3ccdddf8
Comment 17 Quality Engineering 2009-02-06 07:54:38 UTC
Integrated into 'main-golden', will be available in build *200902060201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/3dab3ccdddf8
User: mentlicher@netbeans.org
Log: #154756 - Iterate through the lookup list under the lock to prevent from ConcurrentModificationException.
Listen on the result list for changes, instead of listening directly on Lookup.MetaInf.
Comment 18 Filip Zamboj 2009-04-21 14:11:43 UTC
didn't reproduce on 
Product Version: NetBeans IDE 6.7 Beta (Build 200904192254)
Java: 1.6.0_13; Java HotSpot(TM) 64-Bit Server VM 11.3-b02


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo