Bug 153015 - create annotation for NodeFactory layer registrations
create annotation for NodeFactory layer registrations
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Milos Kleint
issues@projects
: API_REVIEW_FAST
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-12 08:26 UTC by Milos Kleint
Modified: 2009-02-19 22:56 UTC (History)
1 user (show)

See Also:
Issue Type: TASK
:


Attachments
api part of the new annotation (6.69 KB, patch)
2008-11-12 10:33 UTC, Milos Kleint
Details | Diff
rewrite of modules in main repository (45.06 KB, patch)
2008-11-12 10:34 UTC, Milos Kleint
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Milos Kleint 2008-11-12 08:26:52 UTC
see summary
Comment 1 Milos Kleint 2008-11-12 10:33:40 UTC
Created attachment 73664 [details]
api part of the new annotation
Comment 2 Milos Kleint 2008-11-12 10:34:27 UTC
Created attachment 73665 [details]
rewrite of modules in main repository
Comment 3 Milos Kleint 2008-11-12 10:37:51 UTC
please review
Comment 4 Jiri Rechtacek 2008-11-12 12:59:29 UTC

*** This issue has been marked as a duplicate of 152388 ***
Comment 5 Jiri Rechtacek 2008-11-12 13:00:21 UTC
I'm sorry. It's really not a duplicate.
Comment 6 Jesse Glick 2008-11-18 05:15:42 UTC
[JG01] Rather than .intvalue("position", lpr.position()), use .position(lpr.position()), which knows not to write any
attr if the position is unspecified.

Otherwise looks fine to me.
Comment 7 Milos Kleint 2008-11-19 08:23:26 UTC
JG01: done

thanks for review
Comment 8 Jesse Glick 2008-11-19 15:22:22 UTC
Will you also use it in contrib? I see usages in {ada,erlang,scala}.project, autoproject.{core,java,web}, and
portalpack.portlets.genericportlets.
Comment 10 Milos Kleint 2008-11-20 08:06:44 UTC
jglick: i don't plan to update contrib, I leave that to the respective authors. The change in itself is 100% compatible
so it should not pose a problem. 
Comment 11 Jesse Glick 2008-11-20 18:35:20 UTC
Well I dealt with autoproject.* in contrib #bd04bfa2eb75.
Comment 12 Quality Engineering 2008-11-22 04:45:08 UTC
Integrated into 'main-golden', will be available in build *200811220201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/690fffa4fb6e
User: Milos Kleint <mkleint@netbeans.org>
Log: #153015 add annotation to register NodeFactory instances


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo