Bug 152916 - ide does not start on 64-bit Mac OS X 10.5.5 using jdk 1.6_07
ide does not start on 64-bit Mac OS X 10.5.5 using jdk 1.6_07
Status: CLOSED WONTFIX
Product: platform
Classification: Unclassified
Component: -- Other --
6.x
Macintosh Mac OS X
: P2 (vote)
: TBD
Assigned To: Bradley Schmidt
issues@platform
APPLE_JDK_BUG 6364274
: JDK_SPECIFIC, RELNOTE
: 152752 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-11 00:25 UTC by Peter Lam
Modified: 2011-06-09 09:54 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
apple bug report with evaluation (2.94 KB, text/plain)
2008-11-13 23:47 UTC, Peter Lam
Details
6.5 working with jdk 1.6.0_07 (1.09 MB, image/png)
2008-11-26 18:51 UTC, tonybeckham
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Lam 2008-11-11 00:25:27 UTC
Looking at issue 146119, the problem here is different. Issue 146119 is about the ide not launching from finder but ok
from command line.

In this issue, the ide does not come up on both the finder and command line when the system has jdk 1.6_07 as the
default. When starting ide from command line, the following message was displayed. If switching the system to jdk 1.5,
everything's working properly. NetBeans 6.1 also has exactly the same problem as NetBeans 6.5. If the system has jdk
1.6_07 as the default jdk, changing the jdkhome in netbeans.conf does not help and it's still using jdk 1.6_07 as what
the system default is.

MacOS tester$ ./netbeans 
2008-11-06 16:04:00.463 java[7399:10b] Apple AWT Startup Exception : *** -[NSCFArray insertObject:atIndex:]: attempt to
insert nil
2008-11-06 16:04:00.464 java[7399:10b] Apple AWT Restarting Native Event Thread
Comment 1 _ hong_lin 2008-11-11 01:19:20 UTC
Installed same IDE on a 32-bits machine with jdk1.6.0_07, IDE can be started.

Confirmed that this is not the same as issue 146119.
Comment 2 Ken Frank 2008-11-11 03:08:47 UTC
don't know if using the _05 jdk 6 from apple would be ok workaround now to at least still be
able to use a jdk 6 - it was from May, 2008 ?
see http://www.apple.com/support/downloads/javaformacosx105update1.html

ken.frank@sun.com
Comment 3 Lukas Hasik 2008-11-11 07:37:03 UTC
*** Issue 152752 has been marked as a duplicate of this issue. ***
Comment 4 Antonin Nebuzelsky 2008-11-12 14:04:40 UTC
Patrick, Ken, please include this in 6.5 notes.
Comment 5 Lukas Hasik 2008-11-12 14:23:27 UTC
Brad, this should be noted in RN
Comment 6 Jaromir Uhrik 2008-11-12 16:14:35 UTC
petersl, could you please file bug to apple? The bug database is at:
http://bugreport.apple.com 
They will require the System Profile Information to investigate this issue. To obtain a System Profiler Report, select
"About This Mac" from the Apple Menu and click the "More Info" button. This
automatically launches the System Profiler application. 
Once the System Profiler application has been launched please follow the steps below. 
1. Select "Save" from the File menu
2. Keep the format as 'System Profile'
3. Click the "Save" button
4. Append the file to your bug report

Thanks.
Comment 7 Peter Lam 2008-11-12 16:23:37 UTC
Ok, I'll file an apple bug if one has not yet been filed. Thanks for the info.
Comment 8 Peter Lam 2008-11-12 17:33:38 UTC
Just filed the following Apple bug.
Bug ID# 6364274.
Comment 9 Lukas Hasik 2008-11-12 20:39:22 UTC
closing as resolved/later as we might to want to return to this problem when there is response from apple or a workarund
is known.
Comment 10 Ken Frank 2008-11-12 20:57:22 UTC
does the mac jdk 6 _05 work vs the _07, which is topic of this issue ?

if so, can it be used as a workaround jdk to provide at least a fairly recent mac jdk 6
or is it not usable for nb 6.5 for other reasons ?

ken.frank@sun.com
Comment 11 Peter Lam 2008-11-12 22:32:56 UTC
Actually it's good to try the previous jdk 1.6 update. If it works, it's a good workaround.
I'll give it a try to see.
Comment 12 Peter Lam 2008-11-12 22:39:48 UTC
Wouldn't a previous version of jdk 1.6 already be tested already by the ide core team?
I'll give it a try anyway.
Comment 13 Peter Lam 2008-11-12 22:52:31 UTC
Looks like there's nothing I can do here. I tried to install jdk 1.6_05 but after installation was successful, I still
couldn't see it anywhere. From apple's FAQ (below) about removing a java update, the only way is to reinstall the OS.
What a user-friendly OS it is ;-(

Can I remove a Java update after I've installed it?

Java on Mac OS X is updated incrementally through numerous releases. Therefore, the only way to revert to an earlier
Java installation is to reinstall the operating system. The same applies for any other Java-related Software Updates or
Developer Previews. For this reason, it is strongly recommended that Developer Previews of Java on Mac OS X be installed
on non-critical systems. 
Comment 14 Peter Lam 2008-11-12 22:54:32 UTC
Ops, continue on my last comment here. Since jdk 1.6_07 is already on the system, I assume there's no way to put jdk
1.6_05 on it with reinstalling the OS on the system.
Comment 15 Peter Lam 2008-11-13 23:46:41 UTC
Apple could not reproduce the problem. See attached for the apple bug report with evaluation. 
Per apple's request, I created a new user account and downloaded NetBeans 6.1 fresh and installed successfully. And got
the same problem. I updated the apple bug with that info. Let's see what they say again.
Comment 16 Peter Lam 2008-11-13 23:47:15 UTC
Created attachment 73756 [details]
apple bug report with evaluation
Comment 17 tonybeckham 2008-11-26 18:49:59 UTC
I cannot reproduce the issue on my machine.  Using 6.5 native installer and starting from command line with jdkhome set
as 1.6.0_07 the ide comes up fine (see screenshot).

System:
Product Version: NetBeans IDE 6.5 (Build 200811100001)
Java: 1.6.0_07; Java HotSpot(TM) 64-Bit Server VM 1.6.0_07-b06-57
System: Mac OS X version 10.5.5 running on x86_64; MacRoman; en_US (nb)

Comment 18 tonybeckham 2008-11-26 18:51:26 UTC
Created attachment 74196 [details]
6.5 working with jdk 1.6.0_07
Comment 19 tonybeckham 2008-11-26 18:55:32 UTC
With the native installer there is no option to set java version and although I have 1.6.0_07 as default set in java
preferences, NetBeans 6.5 installs with java set to: 1.5.0_16; Java HotSpot(TM) Client VM 1.5.0_16-133
Comment 20 Ken Frank 2008-11-26 18:59:37 UTC
Tony,

are you using the new mac in mpk on which this problem was seen ? 

if not, could you look at that machine - perhaps incorrect or incomplete jdk update or install
might have happened.

ken.frank@sun.com 
Comment 21 tonybeckham 2008-11-26 19:01:52 UTC
No, I did this with my personal machine per discussion w/ Peter and Hong in our QE mtg this morning.
Comment 22 tonybeckham 2008-11-26 19:11:49 UTC
Tried with netbeans installer and no problem launching from command line or from finder.  BTW...I am using full ide for
the test.  I will try in the new lab machine shortly. 
Comment 23 tonybeckham 2008-11-26 19:29:35 UTC
I do not see the problem on lab machine either.

Product Version: NetBeans IDE 6.5 (Build 200811131701)
Java: 1.6.0_07; Java HotSpot(TM) 64-Bit Server VM 1.6.0_07-b06-57
System: Mac OS X version 10.5.5 running on x86_64; MacRoman; en_US (nb)
Comment 24 Peter Lam 2008-12-01 19:36:44 UTC
The reason that it works for you on the lab machine jsqami3 is because the system default jdk was 1.5. What it says in
the About is incorrect and About is showing what's on netbeans_jdkhome option in etc/netbeans.conf. Once I changed the
system jdk links back to jdk 1.6, ide no longer came up. I just commented out the netbeans_jdkhome option in
etc/netbeans.conf and to avoid confusion since this option doesn't seem to work properly on Mac. 
You can try again if you now since the system is now on jdk 1.6.0_07 as default.
Comment 25 tonybeckham 2008-12-01 21:58:47 UTC
Manually changing links for java versions is not supported nor advised by Apple. (See Their Java Dev page
http://developer.apple.com/documentation/Java/Conceptual/Java14Development/01-JavaOverview/JavaOverview.html) I think
the lab machine NetBeans cannot launch now is due to changing the links to java versions as I have not had and cannot
reproduce on my machine.  I do know that setting $JAVA_HOME to your version of choice is a way to get the java version
you want to use instead of manually setting links.

"The Java Home Directory

Some applications look for Java’s home directory ($JAVA_HOME) on the user’s system, especially during installation. If
you need to set this explicitly in a shell script or an installer, set it to /Library/Java/Home/. Setting it to the
target of this symbolic link can result in a broken application for your customers down the road, when Apple ships a
software update that changes the default version of Java, or when the user moves the application to another version of
Mac OS X which has a different default version of Java. Programatically you can use System.getProperty("java.home"), as
you would expect.

/Library/Java/Home/ also contains the bin/ subdirectory where command-line tools like java and javac are found. These
tools match the default version of Java for the system as defined by Apple. Additionally, the Java tools available on
the default path in /usr/bin will dynamically target the top preferred version of Java that the user has chosen for
applications in the Java Preferences application."
Comment 26 mcfedr 2008-12-02 19:16:46 UTC
I have installed using the java SE only and netbeans wont load at all, i have tried changing that default java to all the avalible options, j6, j5, j5 32bit, j4
Starting from the command line it just says segmentation fault, nothing more
Also tried the full installer with no more success
Any other recommendations on how to get netbeans running would be great...i want my netbeans back...!
Comment 27 tonybeckham 2008-12-02 19:54:55 UTC
@mcfedr 
So you cannot even install at all?  Is the segmentation fault message from the OS or the installer?  Are you using the
native DMG installer or another installer?

Do you have other instances of NetBeans installed?  If so do they work?  Have you successfully used prior NB versions
with the same configuration?  Have you tried to delete your user dir (/Users/<username>/.netbeans)?


Comment 28 mcfedr 2008-12-02 22:15:58 UTC
@tonybeckham

The install went fine, but netbeans wouldnt load
Tried removing the .netbeans folder, make any difference
Have tried reinstalling, having removed the .netbeans folder and setting default java to v5 before installing, still no luck

Have previously used netbeans, but on another mac, running 10.4, havnt had it work at all on the 64bit 10.5 macbook
I am using the all option from the netbeans download page, nb. have tried the java se only, same problem

when i run on the command line, this is what i get

/Applications/NetBeans/NetBeans 6.5.app/Contents/MacOS/../Resources/NetBeans/bin/../platform9/lib/nbexec: line 493: 84132 Segmentation fault      
"/System/Library/Frameworks/JavaVM.framework/Versions/1.5/Home/bin/java" -
Djdk.home="/System/Library/Frameworks/JavaVM.framework/Versions/1.5/Home" -classpath "/Applications/NetBeans/NetBeans 
6.5.app/Contents/Resources/NetBeans/platform9/lib/boot.jar:/Applications/NetBeans/NetBeans 
6.5.app/Contents/Resources/NetBeans/platform9/lib/org-openide-modules.jar:/Applications/NetBeans/NetBeans 
6.5.app/Contents/Resources/NetBeans/platform9/lib/org-openide-util.jar:/Applications/NetBeans/NetBeans 
6.5.app/Contents/Resources/NetBeans/platform9/lib/locale/boot_ja.jar:/Applications/NetBeans/NetBeans 
6.5.app/Contents/Resources/NetBeans/platform9/lib/locale/boot_pt_BR.jar:/Applications/NetBeans/NetBeans 
6.5.app/Contents/Resources/NetBeans/platform9/lib/locale/boot_zh_CN.jar:/Applications/NetBeans/NetBeans 
6.5.app/Contents/Resources/NetBeans/platform9/lib/locale/org-openide-modules_ja.jar:/Applications/NetBeans/NetBeans 
6.5.app/Contents/Resources/NetBeans/platform9/lib/locale/org-openide-modules_pt_BR.jar:/Applications/NetBeans/NetBeans 
6.5.app/Contents/Resources/NetBeans/platform9/lib/locale/org-openide-modules_zh_CN.jar:/Applications/NetBeans/NetBeans 
6.5.app/Contents/Resources/NetBeans/platform9/lib/locale/org-openide-util_ja.jar:/Applications/NetBeans/NetBeans 
6.5.app/Contents/Resources/NetBeans/platform9/lib/locale/org-openide-util_pt_BR.jar:/Applications/NetBeans/NetBeans 
6.5.app/Contents/Resources/NetBeans/platform9/lib/locale/org-openide-
util_zh_CN.jar:/System/Library/Frameworks/JavaVM.framework/Versions/1.5/Home/lib/dt.jar" -Dnetbeans.system_http_proxy="DIRECT" -
Dnetbeans.system_http_non_proxy_hosts="" -Dnetbeans.dirs="/Applications/NetBeans/NetBeans 
6.5.app/Contents/Resources/NetBeans/nb6.5:/Applications/NetBeans/NetBeans 
6.5.app/Contents/Resources/NetBeans/ide10:/Applications/NetBeans/NetBeans 
6.5.app/Contents/Resources/NetBeans/java2:/Applications/NetBeans/NetBeans 
6.5.app/Contents/Resources/NetBeans/apisupport1:/Applications/NetBeans/NetBeans 
6.5.app/Contents/Resources/NetBeans/websvccommon1:/Applications/NetBeans/NetBeans 
6.5.app/Contents/Resources/NetBeans/profiler3:/Applications/NetBeans/NetBeans 
6.5.app/Contents/Resources/NetBeans/gsf1:/Applications/NetBeans/NetBeans 6.5.app/Contents/Resources/NetBeans/harness:" -
Dnetbeans.home="/Applications/NetBeans/NetBeans 6.5.app/Contents/Resources/NetBeans/platform9" '-
Dcom.apple.mrj.application.apple.menu.about.name=NetBeans' '-Xdock:name=NetBeans' '-Xdock:icon=/Applications/NetBeans/NetBeans 
6.5.app/Contents/MacOS/../Resources/NetBeans/bin/../nb6.5/netbeans.icns' '-Dnetbeans.importclass=org.netbeans.upgrade.AutoUpgrade' '-
Dnetbeans.accept_license_class=org.netbeans.license.AcceptLicense' '-Xmx409m' '-client' '-Xverify:none' '-Xss2m' '-Xms32m' '-XX:PermSize=32m' '-
XX:MaxPermSize=200m' '-Dapple.laf.useScreenMenuBar=true' '-Dsun.java2d.noddraw=true' org.netbeans.Main --userdir "/Users/mcfedr/.netbeans/6.5" 
"--branding" "nb"

Comment 29 Marian Mirilovic 2008-12-04 15:38:26 UTC
RESOLVED LATER is not allowed for P1/2s
Comment 30 Marian Mirilovic 2008-12-04 15:38:45 UTC
wontfix
Comment 31 Marian Mirilovic 2011-06-09 09:54:33 UTC
v/c


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo