Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 151758 - *Editor* cannot resolve external libs/jars in grails applications.
*Editor* cannot resolve external libs/jars in grails applications.
Status: RESOLVED DUPLICATE of bug 144243
Product: groovy
Classification: Unclassified
Component: Grails
6.x
Macintosh All
: P3 (vote)
: 6.x
Assigned To: Petr Hejl
issues@groovy
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-29 18:23 UTC by runjorel
Modified: 2009-02-19 20:51 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description runjorel 2008-10-29 18:23:22 UTC
When I add external jars/libraries into my grails application (MyGrailsAppDir/lib), the *editor* cannot resolve any of
the classes from those jars.  The Grails application runs fine, but with all the LOC I have that use those external
libs, all those red-lines make it difficult to debug.

Example:
import com.testClass.MyOwnObject     // This jar has been put in MyGrailsAppDir/lib

class AGrailsController{
  def index={def a = new MyOwnObject()}
}

The "def a = new MyOwnObject()" is underlined in red, with a warning saying "Unable to resolve class"

When I run the project, everything runs fine!  No errors.  As I said before, it just makes it difficult to debug.

This issue is with NB6.5RC1

I understand it's a very minor issue.  Thanks for the groovy/grails support!! It's awesome.
Comment 1 Petr Hejl 2008-11-12 14:17:32 UTC
Can you please test the issue with daily build? I can't reproduce it with recent trunk.

For me class is resolved in both controller and ordinary groovy class.
Comment 2 Petr Hejl 2008-11-12 15:32:25 UTC
Actually this is a duplicate of issue 144243.

*** This issue has been marked as a duplicate of 144243 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo