Bug 144243 - JARs in lib/ of a Grails project is not found
JARs in lib/ of a Grails project is not found
Status: RESOLVED FIXED
Product: groovy
Classification: Unclassified
Component: Editor
6.x
All Mac OS X
: P3 with 1 vote (vote)
: 6.x
Assigned To: Petr Hejl
issues@groovy
:
: 151758 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-18 11:47 UTC by sttmjoc0
Modified: 2009-02-19 20:51 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
JAR import error for Grails project (11.87 KB, image/png)
2008-08-18 11:48 UTC, sttmjoc0
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sttmjoc0 2008-08-18 11:47:37 UTC
A JAR file put into lib/ of a Grails project is not found. The editor complains about "unable to resolve class".

Example: put groovyws-all-0.3.1.jar into lib/ and import groovyx.net.ws.WSClient in a Groovy file. The error tooltip
says "unable to resolve class groovyx.net.ws.WSClient".
Comment 1 sttmjoc0 2008-08-18 11:48:19 UTC
Created attachment 67685 [details]
JAR import error for Grails project
Comment 2 galiyosha 2008-09-10 13:10:57 UTC
I have the same issue using the latest nightly build. After placing a JAR in the lib directory, I'm getting an "unable
to resolve class" errors on imports of classes from the JAR. Closing and reopening the project doesn't help, restarting
the whole IDE does.

Product Version: NetBeans IDE Dev (Build 200809100201)
Java: 1.6.0_07; Java HotSpot(TM) Client VM 10.0-b23
System: Linux version 2.6.25.4-rt4 running on i386; UTF-8; sk_SK (nb)
Comment 3 Petr Hejl 2008-11-12 15:32:24 UTC
*** Issue 151758 has been marked as a duplicate of this issue. ***
Comment 4 Petr Hejl 2008-11-12 15:34:38 UTC
Thanks for the report.

What is the way how you put the jar to lib folder? Is it 100% reproducible? I cant reproduce it with current trunk build
as mentioned in issue 151758.
Comment 5 runjorel 2008-11-18 15:58:09 UTC
I have recently tested this issue on RC2, rather than a nightly build, and the issue appears to be resolved.  I cannot
reproduce the issue.

Thank you for the hard work!

Have a good one.
Comment 6 guigouz 2008-12-10 00:00:45 UTC
Netbeans 6.5 final still has this issue. Adding lucene-2.4.0.jar to /lib, and org.apache.lucene.* libraries are not
resolved (even on Java source code).
Will this be fixed only on 7.0 ?
Comment 7 Petr Hejl 2009-02-03 15:54:45 UTC
This should be fixed for 7.0. Perhaps problems with library updates outside of the IDE.

Main a4d342c0f9bb.
Comment 8 Quality Engineering 2009-02-04 08:42:15 UTC
Integrated into 'main-golden', will be available in build *200902040232* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/a4d342c0f9bb
User: phejl@netbeans.org
Log: #144243 JARs in lib/ of a Grails project is not found


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo