Bug 151498 - [65cat] reflect.UndeclaredThrowableException at $Proxy1.fileFolderCreated
[65cat] reflect.UndeclaredThrowableException at $Proxy1.fileFolderCreated
Status: RESOLVED WONTFIX
Product: ide
Classification: Unclassified
Component: Code
6.x
PC All
: P3 (vote)
: 6.x
Assigned To: issues@ide
issues@ide
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT, issue_reviewed
: THREAD
: 151597 155505 157207 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-27 16:57 UTC by sunbiz
Modified: 2010-04-19 12:46 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (18.84 KB, text/plain)
2008-10-27 16:58 UTC, sunbiz
Details
log file (169.86 KB, text/plain)
2008-10-27 17:01 UTC, sunbiz
Details
stacktrace (5.31 KB, text/plain)
2009-07-01 11:43 UTC, Martin Schovanek
Details
stacktrace (5.33 KB, text/plain)
2009-07-19 21:45 UTC, ulfzibis
Details
stacktrace (10.26 KB, text/plain)
2009-09-18 14:51 UTC, Vladimir Kvashin
Details
stacktrace (9.50 KB, text/plain)
2009-11-03 14:57 UTC, Alexander Pepin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sunbiz 2008-10-27 16:57:18 UTC
Build: NetBeans IDE Dev (Build 200810240201)
VM: Java HotSpot(TM) Client VM, 11.0-b15, Java(TM) SE Runtime Environment, 1.6.0_10-rc2-b32
OS: Windows Vista, 6.0, x86

User comments: Added Web Frameworks to an existing Spring project and got this exception
STACKTRACE: (first 10 lines)
java.lang.reflect.UndeclaredThrowableException
        at $Proxy.fileFolderCreated(.java:0)
        at org.openide.filesystems.FCLSupport$DispatchEventWrapper.dispatchEventImpl(FCLSupport.java:133)
        at org.openide.filesystems.FCLSupport$DispatchEventWrapper.dispatchEvent(FCLSupport.java:122)
        at org.openide.filesystems.FCLSupport.dispatchEvent(FCLSupport.java:99)
        at org.openide.filesystems.FileObject$ED.dispatch(FileObject.java:953)
        at org.openide.filesystems.FileSystem$EventDispatcher.run(FileSystem.java:918)
        at org.openide.filesystems.EventControl.dispatchEvent(EventControl.java:77)
        at org.openide.filesystems.FileSystem.dispatchEvent(FileSystem.java:537)
        at org.openide.filesystems.FileObject.dispatchEvent(FileObject.java:466)
        at org.openide.filesystems.FileObject.fireFileFolderCreatedEvent(FileObject.java:426)
Comment 1 sunbiz 2008-10-27 16:58:14 UTC
Created attachment 72701 [details]
stacktrace
Comment 2 sunbiz 2008-10-27 17:01:32 UTC
Created attachment 72702 [details]
log file
Comment 3 Lukas Hasik 2008-10-27 18:33:44 UTC
reassigning, this is possible cause of deadlock

java.lang.IllegalStateException: Should not acquire Children.MUTEX while holding ProjectManager.mutex()
... 
org.netbeans.modules.visualweb.project.jsf.framework.JsfProjectTemplate.instantiateFile(JsfProjectTemplate.java:137)
        at
org.netbeans.modules.visualweb.project.jsf.framework.JsfProjectTemplate.instantiateFile(JsfProjectTemplate.java:145)
Comment 5 _ potingwu 2008-10-29 17:05:45 UTC
*** Issue 151597 has been marked as a duplicate of this issue. ***
Comment 6 _ potingwu 2008-10-29 19:14:35 UTC
In order to fix this issue, we need to separate the 'Folder creating' and 'Java file creating' in JsfProjectTemplate.xml!

I.e., They are currently under in one single xml parsing-n-creating action. Since 'Java file creating' needs to be under
ProjectManager.mutex(), while 'Folder creating' invokes another Children.MUTEX!

BTW, I still can't reproduce it. Do you see this happened always? Any steps that can always reproduce this issue?
Comment 7 _ potingwu 2008-11-20 23:38:07 UTC
.
Comment 8 _ potingwu 2009-01-02 17:53:43 UTC
*** Issue 155505 has been marked as a duplicate of this issue. ***
Comment 9 _ potingwu 2009-01-21 16:50:33 UTC
*** Issue 157207 has been marked as a duplicate of this issue. ***
Comment 10 Exceptions Reporter 2009-06-24 15:34:36 UTC
This issue already has 24 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=133241
Comment 11 Martin Schovanek 2009-07-01 11:43:20 UTC
Build: NetBeans IDE Dev (Build 200907010200)
VM: Java HotSpot(TM) Client VM, 1.5.0_19-137, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_19-b02-304
OS: Mac OS X, 10.5.7, i386

User Comments: 
Just closed J2SEE Freeform project.

Stacktrace: 
java.lang.IllegalStateException: Should not acquire Children.MUTEX while holding ProjectManager.mutex()
        at org.openide.nodes.Children$ProjectManagerDeadlockDetector.execute(Children.java:1808)
        at org.openide.util.Mutex.postRequest(Mutex.java:1245)
        at org.openide.util.Mutex.postRequest(Mutex.java:1209)
        at org.openide.util.Mutex.postWriteRequest(Mutex.java:582)
        at org.openide.nodes.Children$Keys.applyKeys(Children.java:1513)
        at org.openide.nodes.Children$Keys.setKeys(Children.java:1457)
Comment 12 Martin Schovanek 2009-07-01 11:43:26 UTC
Created attachment 84234 [details]
stacktrace
Comment 13 ulfzibis 2009-07-19 21:45:00 UTC
Build: NetBeans IDE Dev (Build 200907150249)
VM: Java HotSpot(TM) Client VM, 14.0-b16, Java(TM) SE Runtime Environment, 1.6.0_14-b08
OS: Windows XP, 5.1, x86

User Comments: 
On closing a freeform project

Stacktrace: 
java.lang.IllegalStateException: Should not acquire Children.MUTEX while holding ProjectManager.mutex()<br/>
        at org.openide.nodes.Children$ProjectManagerDeadlockDetector.execute(Children.java:1808)<br/>
        at org.openide.util.Mutex.postRequest(Mutex.java:1245)<br/>
        at org.openide.util.Mutex.postRequest(Mutex.java:1209)<br/>
        at org.openide.util.Mutex.postWriteRequest(Mutex.java:582)<br/>
        at org.openide.nodes.Children$Keys.applyKeys(Children.java:1513)<br/>
        at org.openide.nodes.Children$Keys.setKeys(Children.java:1457)<br/>
Comment 14 ulfzibis 2009-07-19 21:45:05 UTC
Created attachment 84913 [details]
stacktrace
Comment 15 Vladimir Kvashin 2009-09-18 14:51:34 UTC
Build: NetBeans IDE Dev (Build 090918)
VM: Java HotSpot(TM) Server VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: SunOS, 5.10, x86

User Comments: 
I was creating a project from existing sources, when exception occurred	

Stacktrace: 
java.lang.IllegalStateException: Should not acquire Children.MUTEX while holding ProjectManager.mutex()
        at org.openide.nodes.Children$ProjectManagerDeadlockDetector.execute(Children.java:1808)
        at org.openide.util.Mutex.postRequest(Mutex.java:1245)
        at org.openide.util.Mutex.postRequest(Mutex.java:1209)
        at org.openide.util.Mutex.postWriteRequest(Mutex.java:582)
        at org.openide.nodes.Children$Keys.applyKeys(Children.java:1513)
        at org.openide.nodes.Children$Keys.setKeys(Children.java:1457)
Comment 16 Vladimir Kvashin 2009-09-18 14:51:40 UTC
Created attachment 87916 [details]
stacktrace
Comment 17 Alexander Pepin 2009-11-03 14:57:34 UTC
Build: NetBeans IDE Dev (Build cnd-main-2095-on-091103)
VM: Java HotSpot(TM) Client VM, 14.0-b16, Java(TM) SE Runtime Environment, 1.6.0_14-b08
OS: Linux, 2.6.28-15-generic, i386

User Comments: 
Steps to reproduce: 
- add remote Linux (Ubuntu) host with GNU tool collection using Smart Secure Copy
- set it as default
- untar litesql-0.3.5 project
- create a project from existing source using  litesql-0.3.5
Result: Exception appears

Stacktrace: 
java.lang.IllegalStateException: Should not acquire Children.MUTEX while holding ProjectManager.mutex()
        at org.openide.nodes.Children$ProjectManagerDeadlockDetector.execute(Children.java:1809)
        at org.openide.util.Mutex.postRequest(Mutex.java:1245)
        at org.openide.util.Mutex.postRequest(Mutex.java:1209)
        at org.openide.util.Mutex.postWriteRequest(Mutex.java:582)
        at org.openide.nodes.Children$Keys.applyKeys(Children.java:1514)
        at org.openide.nodes.Children$Keys.setKeys(Children.java:1458)
Comment 18 Alexander Pepin 2009-11-03 14:57:39 UTC
Created attachment 90450 [details]
stacktrace
Comment 19 Alexander Pepin 2009-11-03 15:04:08 UTC
It's definitely not a visualweb issue. Please investigate and reassign to the right component.
Comment 20 Jesse Glick 2009-11-03 15:48:37 UTC
There seem to be a bunch of different culprits in these stack traces. Offhand I see
cnd.makeproject.ui.MakeLogicalViewProvider and java.project.support.ui.PackageViewChildren. Milan perhaps you can
manually classify the responsible modules and file individual bug reports accordingly?

(Tonda and I are discussing how to better handle this kind of thing mechanically.)
Comment 21 Milan Kubec 2009-11-04 10:33:31 UTC
I've filed issue #175996 and issue #175997. Other reports are probably no more relevant.
Comment 22 Marian Mirilovic 2010-04-19 12:46:26 UTC
> I've filed issue #175996 and issue #175997. Other reports are probably no more
relevant.
so closing this one


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo