Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 151469 - IDE doesn't detect started Java DB
IDE doesn't detect started Java DB
Status: RESOLVED WORKSFORME
Product: db
Classification: Unclassified
Component: Derby
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@db
:
: 148815 (view as bug list)
Depends on:
Blocks: 152673
  Show dependency treegraph
 
Reported: 2008-10-27 14:12 UTC by Roman Mostyka
Modified: 2009-06-11 15:25 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Mostyka 2008-10-27 14:12:10 UTC
1. Start Java DB outside NetBeans.
2. Rightclick some sample Java DB connection and choose "Connect".

Result: Message "<java.net.BindException: Address already in use: JVM_Bind> appears and IDE hungs up for some time. But
path to started Java DB is the same as in NetBeans.
Comment 1 John Baker 2008-10-29 20:18:31 UTC
I'm unable to reproduce.

From your error it looks like there was already a Java DB running in NetBeans

Here's what I did:
1) Make sure Java DB had not been started from NetBeans
2) Start Java DB outside NetBeans
3) In NetBeans try to connect to the Travel sample connection

Connection succeeded.

There is a harmless message, "Could not listen on port 1527 on host localhost." but I can expand the connection,view the
tables and execute queries
Comment 2 Roman Mostyka 2008-10-30 19:35:43 UTC
I'm not only see the error message, but also unable to expand DB's node.
I reproduce this issue on Windows XP.
Comment 3 John Baker 2008-10-30 19:38:39 UTC
Please provide the complete steps to reproduce.
I cannot reproduce

Make sure that Java DB had not already been started in NetBeans
Comment 4 Roman Mostyka 2008-10-31 13:32:44 UTC
your steps are exact.
1) Make sure Java DB had not been started from NetBeans. I stopped Java DB from NetBeans.
2) Start Java DB outside NetBeans.
3) In NetBeans try to connect to the Travel sample connection.

I tried on Windows XP and got message that address is already in use. I also tried on Mac OS X and as you I got message
"Could not listen on port 1527 on host localhost.", but I couldn't expand the connection node.
Are you sure that you start outside NetBeans the same Java DB, which is used by NetBeans?
Comment 5 John Baker 2008-11-18 16:20:16 UTC
I haven't been able to reproduce this issue yet, so I can't commit to fixing this for 7.0
Comment 6 John Baker 2008-12-18 00:54:41 UTC
Did you have 2 instances of NetBeans running ?
Comment 7 Roman Mostyka 2008-12-18 16:28:12 UTC
No, I have only one NetBeans started.
Have you tried on Windows XP? Actually I tried only on this platform and don't know if this issue is reproducible on other.
Comment 8 Jiri Rechtacek 2009-02-10 15:34:27 UTC
Reassigned to new owner.
Comment 9 Jiri Rechtacek 2009-05-12 15:58:42 UTC
*** Issue 148815 has been marked as a duplicate of this issue. ***
Comment 10 Jiri Skrivanek 2009-06-11 15:25:02 UTC
It works for me. I did:

- copy files from <HOME>/.netbeans-derby to <JAVA_DB_INSTALL>/bin
- run <JAVA_DB_INSTALL>/bin/startNetworkServer.bat
- connect to sample database in IDE

Product Version: NetBeans IDE Dev (Build 090611)
Java: 1.6.0_13; Java HotSpot(TM) Client VM 11.3-b02
System: Windows Vista version 6.0 running on x86; Cp1250; cs_CZ (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo