Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 149260 - Source text becomes garbled when scrolling down large files under Linux
Source text becomes garbled when scrolling down large files under Linux
Status: VERIFIED INVALID
Product: editor
Classification: Unclassified
Component: Navigation
6.x
PC Linux
: P3 (vote)
: 6.x
Assigned To: issues@editor
issues@editor
:
: 153857 153875 154649 154680 156405 156659 157030 157489 157970 161254 164055 168101 169044 178326 188274 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-06 16:05 UTC by donaldm
Modified: 2010-07-09 07:46 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Garbled source when scrolling down large file in Linux (160.21 KB, image/jpeg)
2008-10-06 16:07 UTC, donaldm
Details

Note You need to log in before you can comment on or make changes to this bug.
Description donaldm 2008-10-06 16:06:01 UTC
When scrolling down Java source files where (on my system) the file has more than 1927 lines the source text becomes
garbled. It does not appear to be directly related to memory as the garbling does not occur no matter how many
characters are inserted on the 1927th line. The line the cursor is on is displayed correctly. This occurs using Linux
but not in Windows.

Linux Kernel: 2.6.25
X.Org X Server 1.4.2
X Protocol Version 11, Revision 0
KDE 3.5.9
Netbeans 6.1, 6.5 (attachment was created from screen shot of dev-200810041417)

See attachment image for an example (or http://196.25.83.130/netbeans-bug.jpg).
Comment 1 donaldm 2008-10-06 16:07:47 UTC
Created attachment 71217 [details]
Garbled source when scrolling down large file in Linux
Comment 2 Miloslav Metelka 2008-10-06 16:37:10 UTC
Do you use Sun's JDK or OpenJDK? What's an output from "java -version"? Thanks.
Comment 3 Vitezslav Stejskal 2008-10-07 09:05:58 UTC
Is this reliably reproducible? Does it always happen with this file? Does it happen with other files too?
Comment 4 Miloslav Metelka 2008-10-07 10:18:10 UTC
Info from the user:
Sun JDK
java version "1.6.0_07"
Java(TM) SE Runtime Environment (build 1.6.0_07-b06)
Java HotSpot(TM) Client VM (build 10.0-b23, mixed mode, sharing)
Comment 5 Petr Dvorak 2008-10-07 14:55:06 UTC
Product Version: NetBeans IDE Dev (Build 200810011401)
Java: 1.6.0_07-rev; Java HotSpot(TM) Client VM 10.0-b24
System: Linux version 2.6.24-19-generic running on i386; UTF-8; en_US (nb)

I was unable to reproduce the issue with files from TS_65_JavaEditorPerformance (they are much longer than some 2000 lines).

Donaldm, can you please send us a sample file that causes the problems?
Comment 6 donaldm 2008-10-08 13:50:59 UTC
The problem was not in Netbeans as I could replicate it in a standard Java program opening
the same file in a JEditorPane. It appears to be a problem with Java
and the Intel i915 driver of the video card in the motherboard I am
using. A similar machine I have with a NVidia card and driver works
fine and the VESA driver on the original machine also works.
Comment 7 Petr Dvorak 2008-10-09 18:18:07 UTC
Verified
Comment 8 Michel Graciano 2008-11-25 17:55:30 UTC
*** Issue 153875 has been marked as a duplicate of this issue. ***
Comment 9 Michel Graciano 2008-11-25 19:00:22 UTC
Any idea how to solve it or a workaround?
Comment 10 Michel Graciano 2008-11-25 19:28:58 UTC
hummm, I think I solved the problem just fixing vga driver at my xorg.conf file. The instructions from
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/238629 help me about it.
I changed my xorg.conf from

Section "Device"
	Identifier	"Configured Video Device"
EndSection

to

Section "Device"
	Identifier	"Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller"
        Option          "AccelMethod"           "xaa"
        Option          "RenderAccel"           "true"
EndSection

For now, I can't reproduce the issue.
Comment 11 paulononaka 2008-11-26 19:25:05 UTC
*** Issue 153857 has been marked as a duplicate of this issue. ***
Comment 12 Jiri Prox 2008-12-05 08:45:32 UTC
*** Issue 154649 has been marked as a duplicate of this issue. ***
Comment 13 Petr Dvorak 2008-12-05 09:40:31 UTC
*** Issue 154680 has been marked as a duplicate of this issue. ***
Comment 14 Michel Graciano 2008-12-18 16:20:48 UTC
I updated wiki with the details in http://wiki.netbeans.org/TaT_SolvingEditorGarbledText

Regards
Comment 15 Petr Dvorak 2008-12-19 19:41:07 UTC
Awesome, hmichel... Thank you for this...
Comment 16 Jiri Prox 2009-01-07 10:33:38 UTC
*** Issue 156405 has been marked as a duplicate of this issue. ***
Comment 17 Jiri Prox 2009-01-13 10:15:39 UTC
*** Issue 156659 has been marked as a duplicate of this issue. ***
Comment 18 Jiri Prox 2009-01-27 12:24:43 UTC
*** Issue 157489 has been marked as a duplicate of this issue. ***
Comment 19 nvarun 2009-01-28 12:08:26 UTC
With respect to the guidelines of User FAQ Wiki, I have changed the URL 
(http://wiki.netbeans.org/TaT_SolvingEditorGarbledText
) to make it “FAQSolvingEditorGarbledText”, and that will be updated here as well;
http://wiki.netbeans.org/NBCDTipsAndTricks#section-NBCDTipsAndTricks-GeneralTopics
Comment 21 Jiri Prox 2009-02-05 09:33:11 UTC
*** Issue 157970 has been marked as a duplicate of this issue. ***
Comment 22 Petr Dvorak 2009-02-05 09:35:20 UTC
Here is the correct link: http://wiki.netbeans.org/FaqSolvingEditorGarbledText
Comment 23 wklaczynski 2009-03-12 02:30:02 UTC
Use XAA is not advisable, and often does not work
I use options Exa options MigrationHeuristic and ExaNoComposite

        Option      "AccelMethod" "EXA"
        Option      "MigrationHeuristic" "greedy"
        Option      "ExaNoComposite" "false"
Comment 24 Jiri Prox 2009-03-26 14:39:16 UTC
*** Issue 161254 has been marked as a duplicate of this issue. ***
Comment 25 Jiri Prox 2009-04-17 17:08:40 UTC
*** Issue 157030 has been marked as a duplicate of this issue. ***
Comment 26 Jiri Prox 2009-04-29 13:45:34 UTC
*** Issue 164055 has been marked as a duplicate of this issue. ***
Comment 27 Michel Graciano 2009-07-04 01:44:33 UTC
*** Issue 168101 has been marked as a duplicate of this issue. ***
Comment 28 Jiri Prox 2009-07-23 13:30:44 UTC
*** Issue 169044 has been marked as a duplicate of this issue. ***
Comment 29 danstr179 2009-12-09 13:09:45 UTC
*** Bug 178326 has been marked as a duplicate of this bug. ***
Comment 30 Vitezslav Stejskal 2010-07-09 07:46:13 UTC
*** Bug 188274 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo