Bug 148992 - EQ hung while opening *.java from NBM project
EQ hung while opening *.java from NBM project
Status: RESOLVED DUPLICATE of bug 173109
Product: apisupport
Classification: Unclassified
Component: Project
6.x
All All
: P3 (vote)
: TBD
Assigned To: Jesse Glick
issues@apisupport
: PERFORMANCE, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 18:03 UTC by Jesse Glick
Modified: 2010-03-11 12:41 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump (17.29 KB, text/plain)
2008-10-02 18:06 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2008-10-02 18:03:07 UTC
081001. After starting NB, I used File > Open to open a unit test from an NBM project. The IDE hung while a module scan
completed.

Looking at the thread dump, "Java Node Badge Processor" is blocked waiting for the CP of the project, calculation of
which can require a universe scan. That in itself should not be a big problem because the badge is calculated
asynchronously. The problem is that EQ is waiting for the document to be loaded in "Document Processing", which needs to
know javac.source. This should be a quick evaluator call - isModuleListDependentValue would be false - but Evaluator
nonetheless blocks calling delegatingEvaluator(false).

Probably delegatingEvaluator(false) should be changed to return delegate immediately without waiting for the monitor in
case !reset, which would allow document loading to proceed unhindered while expensive calculations wait.
Comment 1 Jesse Glick 2008-10-02 18:06:33 UTC
Created attachment 71063 [details]
Thread dump
Comment 2 Jesse Glick 2010-03-11 12:41:02 UTC

*** This bug has been marked as a duplicate of bug 173109 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo