Bug 173109 - Performance improvements in module list scan
Performance improvements in module list scan
Status: RESOLVED FIXED
Product: apisupport
Classification: Unclassified
Component: Project
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jesse Glick
issues@apisupport
: PERFORMANCE
: 148992 170150 172321 180299 (view as bug list)
Depends on: 172321
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-25 14:26 UTC by rmichalsky
Modified: 2010-03-26 07:51 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (256.00 KB, application/nps)
2010-03-17 13:19 UTC, Alexander Simon
Details
nps snapshot (256.00 KB, application/nps)
2010-03-26 07:51 UTC, Ivan Sidorkin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rmichalsky 2009-09-25 14:26:38 UTC
This is a follow-up of issue #169040, some more performance improvements should be made. Notably:
1) Change all-universe scan to transitive-deps-only scan
2) get rid of ModuleList.getAllEntriesSoft()

See issue #169040 for details.
Comment 1 rmichalsky 2009-09-25 14:27:22 UTC
After 6.8.
Comment 2 Jesse Glick 2010-02-04 13:45:49 UTC
*** Bug 172321 has been marked as a duplicate of this bug. ***
Comment 3 Jesse Glick 2010-03-10 15:33:34 UTC
core-main #9083cfc6780c
Comment 4 Jesse Glick 2010-03-11 12:21:33 UTC
*** Bug 170150 has been marked as a duplicate of this bug. ***
Comment 5 Jesse Glick 2010-03-11 12:41:02 UTC
*** Bug 148992 has been marked as a duplicate of this bug. ***
Comment 6 Jesse Glick 2010-03-11 17:32:03 UTC
*** Bug 180299 has been marked as a duplicate of this bug. ***
Comment 7 Quality Engineering 2010-03-12 04:30:40 UTC
Integrated into 'main-golden', will be available in build *201003120200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/9083cfc6780c
User: Jesse Glick <jglick@netbeans.org>
Log: #173109: more incremental scan of nb.org modules.
Comment 8 Alexander Simon 2010-03-17 13:19:17 UTC
Created attachment 95291 [details]
nps snapshot
Comment 9 Alexander Simon 2010-03-17 13:33:44 UTC
It seems not fixed because last issue was reproduced on build with change set http://hg.netbeans.org/main/rev/9083cfc6780c
Comment 10 Jesse Glick 2010-03-17 16:30:40 UTC
(In reply to comment #9)
> It seems not fixed

Please do not reopen. Open separate issues for problems you see in current versions.

> last issue was reproduced

What is the "last issue"? (Please answer in separate issue, not here.)
Comment 11 Alexander Simon 2010-03-17 18:43:50 UTC
(In reply to comment #10)
> What is the "last issue"? (Please answer in separate issue, not here.)
It is automatically created attachment with snapshot.
See: Comment #8
Snapshot was taken on NB built with changes mentioned in Comment #7
So it is justification to reopen issue, is not it?
Comment 12 Alexander Simon 2010-03-17 19:07:04 UTC
Sorry it seems a bug on netbeans site (or in IDE in automatically detection of duplicated issue).
I see that netbeans site (or IDE) wrongly attached snapshot to issue.
Comment 13 Jesse Glick 2010-03-17 21:26:20 UTC
If there are new performance issues, they are probably for different reasons than the old ones, so would be better covered in a separate issue.
Comment 14 Alexander Simon 2010-03-18 08:40:32 UTC
My slowness report is 354378, see:
http://statistics.netbeans.org/analytics/detail.do?id=155418
Indeed reports' issue is 173109.
Comment 15 Jesse Glick 2010-03-19 17:58:02 UTC
It's some unrelated issue (which I might or might not know how to reproduce). The module list is not being scanned anywhere in your snapshot that I can see.
Comment 16 Ivan Sidorkin 2010-03-26 07:51:15 UTC
Created attachment 95886 [details]
nps snapshot


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo