Bug 148204 - Windows: User input does not work in output window during debug
Windows: User input does not work in output window during debug
Status: RESOLVED WONTFIX
Product: cnd
Classification: Unclassified
Component: Debugger
6.x
All Windows 7
: P1 (vote)
: 6.x
Assigned To: Egor Ushakov
issues@cnd
:
Depends on: 143501 182147
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-24 13:04 UTC by Egor Ushakov
Modified: 2010-07-05 07:16 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Egor Ushakov 2008-09-24 13:04:43 UTC
See issue 143501. It was fixed, but current gdb from cygwin does not work with input redirection.
Gdb command :
run < input
just passes "< input" as arguments to the program.
I did not find the way how to deal with it, so I create this issue and close the general one (issue 143501).
Comment 1 Egor Ushakov 2008-09-24 18:13:33 UTC
This issue does not affect remote development,
simple workaround is to use external console.
Comment 2 Egor Ushakov 2009-03-16 13:49:38 UTC
lowering priority to P3 because of the simple workaround - use external terminal
Comment 3 Egor Ushakov 2009-10-12 11:10:10 UTC
still requires fixing
Comment 4 Egor Ushakov 2009-10-20 15:43:58 UTC
another workaround is to use attach
Comment 5 Egor Ushakov 2010-04-07 13:49:03 UTC
now there is yet another workaround - internal terminal
Comment 6 gilibuzaglo 2010-07-04 13:15:03 UTC
Hi
I cannot debug my cli application because no input is transefered to my application.
external terminal - valid only for c++ and this is a java app.
use attach - Its very combersome to compile the application, run it from a cmd window and then attach to it.
internal terminal - does not work - I tried opening windoe->output terminal
pressed local terminal received null message.
Comment 7 gilibuzaglo 2010-07-05 07:06:45 UTC
It seems the usage of jline for commands history was the cause for the problem.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo