Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 148079 - org.mozilla.nb.javascript classes are loaded on NetBeans startup with LimeWire project
org.mozilla.nb.javascript classes are loaded on NetBeans startup with LimeWir...
Status: VERIFIED DUPLICATE of bug 148179
Product: javascript
Classification: Unclassified
Component: Editor
6.x
PC Windows XP
: P2 (vote)
: TBD
Assigned To: Torbjorn Norbye
issues@javascript
http://wiki.netbeans.org/FitnessViaWh...
: PERFORMANCE, TEST
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-23 18:12 UTC by Alexander Kouznetsov
Modified: 2009-02-27 14:26 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Stacktraces (83.51 KB, text/plain)
2008-09-23 18:13 UTC, Alexander Kouznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kouznetsov 2008-09-23 18:12:45 UTC
Performance test reports that the following classes are loaded on NetBeans startup with LimeWare project:

    org.mozilla.nb.javascript.Callable
    org.mozilla.nb.javascript.CompilerEnvirons
    org.mozilla.nb.javascript.ConstProperties
    org.mozilla.nb.javascript.Context
    org.mozilla.nb.javascript.ContextFactory
    org.mozilla.nb.javascript.Decompiler
    org.mozilla.nb.javascript.DefaultErrorReporter
    org.mozilla.nb.javascript.ErrorReporter
    org.mozilla.nb.javascript.Function
    org.mozilla.nb.javascript.IRFactory
    org.mozilla.nb.javascript.Interpreter
    org.mozilla.nb.javascript.Kit
    org.mozilla.nb.javascript.Node
    org.mozilla.nb.javascript.ObjArray
    org.mozilla.nb.javascript.ObjToIntMap
    org.mozilla.nb.javascript.Parser
    org.mozilla.nb.javascript.Parser$NoOpDecompiler
    org.mozilla.nb.javascript.ScriptOrFnNode
    org.mozilla.nb.javascript.ScriptRuntime
    org.mozilla.nb.javascript.Scriptable
    org.mozilla.nb.javascript.ScriptableObject
    org.mozilla.nb.javascript.ScriptableObject$Slot
    org.mozilla.nb.javascript.TokenStream
    org.mozilla.nb.javascript.UniqueTag
    org.mozilla.nb.javascript.debug.DebuggableObject
    org.mozilla.nb.javascript.optimizer.Codegen

Please don't load these classes unless they are really necessary.
Comment 1 Alexander Kouznetsov 2008-09-23 18:13:31 UTC
Created attachment 70350 [details]
Stacktraces
Comment 2 Torbjorn Norbye 2008-09-30 00:57:10 UTC
If these classes are loaded (see issue 148179 for more information on that), then they would be loaded because the
JavaScript parser is running - that would be a duplicate of issue 148179.

*** This issue has been marked as a duplicate of 148179 ***
Comment 3 Alexander Kouznetsov 2008-09-30 16:18:53 UTC
ok


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo