Bug 146824 - No way to disconnect from any VFS
No way to disconnect from any VFS
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Code
6.x
All All
: P3 with 3 votes (vote)
: 7.1
Assigned To: Tomas Stupka
issues@versioncontrol
: PLAN
: 155626 192254 192255 198121 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-10 18:03 UTC by alosii
Modified: 2011-07-21 14:34 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alosii 2008-09-10 18:03:57 UTC
There is no way to change or disconnect from a repository
Comment 1 Tomas Stupka 2008-09-10 19:03:29 UTC
there is the relocate action, in versioning main menu, but i'm afraid that's not what you are asking for.

could you, please, elaborate...
Comment 2 alosii 2008-09-10 20:23:55 UTC
Yes. Suppose you have a Project connected to a SVN repocitory. I no longer want to share this proyect. I want a "Disconnect from SVN Repo" menu or 
something similar to the disconnect found in Eclipse's  "Team->Disconnect" 
Comment 3 alosii 2009-06-01 23:34:19 UTC
Is this comming out soon? Did I made my self clear?
Comment 4 brunogh 2009-07-14 03:13:23 UTC
Yes, I am looking for something like that, pretty like the one in Eclipse.
Comment 5 locked 2009-12-01 05:10:30 UTC
The use-case is indeed not very common but nevertheless I appreciate the RFE.
Sometimes I check out source from a repository, that I have no write access to.
When I want to archive the source, put it online or just give the source to a colleague (maybe the repo hast just gone away) I don't want all the ".svn"s in the archive.

Actually the most recent reason why I wanted such a feature was that I somehow killed my repo. There was just something very weired between my local code and the repository. So I just killed the repo and wanted to reimport my code from scratch into a new repository. So that I could start without any svn information at all. Disconnecting the project from svn would have been nice. So I had to delete all .svn folders manually using Windows explorer's search.

Changed platform to "all" as it doesn't only affect mac
Comment 6 Michel Graciano 2009-12-22 08:27:15 UTC
Well, will be great have this feature for CVS too, probably for another VFS too. I will change the subject as defined in our VOC meeting and see what is possible in the future. BTW, I am not sure if the component is correct now. Thanks
Comment 7 lucrus 2010-02-05 01:38:55 UTC
In 6.8/Linux deleting .svn subdirs does not work for me: it simply 
screws up the svn connection (it says that the local directory is not a 
working copy, but it remembers the connection to the svn server).

In case you need to move the project to another repository, here is how I did it:
1. close NB
2. delete all .svn subdirs in the project
3. import the sources into the new repo using svn command line/rapidsvn/whatever except NB
4. use NB to checkout the sources from the new repo into a new project
Comment 8 dalin 2010-08-24 07:27:41 UTC
I would vote this feature down if that was possible.  Such a rarely used feature for something that is easy to do outside of the IDE would do not much more than clutter the interface.  

I admire Netbeans' simplicity.  Because Eclipse implements a feature is reason for Netbeans not to.  Eclipse's folly has been to include an option for absolutely everything.  The result has been an unusable IDE.  I hope that Netbeans does not go down the same path.
Comment 9 Ondrej Vrabec 2010-08-24 08:00:21 UTC
This does not necessarily mean the 'permanent disconnect' - permanently deleting the metadata (i'm actually against it). We in fact could track a set of 'unversioned' folders for each VCS - that would mean that e.g. the mercurial plugin would give up on handling the working copy (as long as the repository is amongst these folders) and another VCS would get the chance to acquire the ownership of files in the tree.
Comment 10 lucrus 2010-08-24 08:26:04 UTC
@dalin: I finally gave up using NB VCS beacuse of this. Now, using external git shell commands, I can tell I'm happier than before, so it did more good than harm for me, but I suspect that, from a NB developers point of view, this is a net loss.
Comment 11 Tomas Stupka 2010-08-24 11:18:33 UTC
see two issues here:
1.) get rid of the .svn metadata - stop versioning a foder tree - see #73949 that should more or less solve the problem
2.) make the ide to ignore a folder by a specific vcs - agree with ovrabec that we could implement it. For now it's already possible to stop versioning to care about a specific folder, but that applies for all vcs, not only a specific one - see #105161 on how to use the "unversionedFolders" property
Comment 12 Tomas Stupka 2010-11-25 13:42:53 UTC
*** Bug 192254 has been marked as a duplicate of this bug. ***
Comment 13 Tomas Stupka 2010-11-25 13:43:22 UTC
*** Bug 192255 has been marked as a duplicate of this bug. ***
Comment 14 Ondrej Vrabec 2010-11-29 14:03:23 UTC
The git support already provides this, see http://hg.netbeans.org/core-main/rev/74015c0ff46c. However it's an experimental implementation, so we'll wait a while and if it proves correctly coded and does not result in any undesired effects, we can transplant the code to other VCSs.
Comment 15 Tomas Stupka 2011-05-10 12:58:23 UTC
*** Bug 198121 has been marked as a duplicate of this bug. ***
Comment 16 Tomas Stupka 2011-05-10 13:57:35 UTC
*** Bug 155626 has been marked as a duplicate of this bug. ***
Comment 17 Ondrej Vrabec 2011-07-12 15:17:25 UTC
fix: http://hg.netbeans.org/core-main/rev/2443a9005fb2
Comment 18 Ondrej Vrabec 2011-07-12 15:19:34 UTC
A repository/working copy may be disconnected from a version control system using Team -> VERSIONING -> Disconnect. If you disconnect a folder this way, you may reconnect it back with Team -> Versioning -> Connect
Comment 19 Quality Engineering 2011-07-13 13:58:24 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/2443a9005fb2
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: Issue #146824 - No way to disconnect from any VFS
Comment 20 Quality Engineering 2011-07-21 14:34:34 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/d01f492bbcf1
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: Bug #146824 - No way to disconnect from any VFS
making the disconnect action more visible, listed in the 1st level of the main menu


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo