Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 145029 - [65cat] [php] Code Completion includes unused Javascripts methods
[65cat] [php] Code Completion includes unused Javascripts methods
Status: RESOLVED WONTFIX
Product: javascript
Classification: Unclassified
Component: Editor
6.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: Marek Fukala
issues@javascript
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-25 16:20 UTC by nvarun
Modified: 2009-04-24 16:20 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Its a sample PHP app contains 2 zip files, one with metadata and other with src (2.13 KB, application/x-compressed)
2008-08-25 19:50 UTC, nvarun
Details
It contains 3 screenshots depicting the scenario (315.69 KB, application/x-compressed)
2008-08-25 19:52 UTC, nvarun
Details

Note You need to log in before you can comment on or make changes to this bug.
Description nvarun 2008-08-25 16:20:16 UTC
[ JDK VERSION : 1.6.0_05 ]

I have some interesting observations to share, though the issues are
not show stoppers. Still, its quite interesting, would like to know,
if they are reproducible?

If you create a PHP application, and then create some "js" files,
code completion (CC), what it does it includes functions of the "js"
files as well. Now, interesting to note, that if I don't include that
script in my webpage, its functions still shows up in CC, I invoke
them, but when I deploy, I do find a problem, as those functions
don't work, as their script was not included in the webpage.

What can be done?

----Issue found in Build #080823 and 6.5 Beta
Comment 1 nvarun 2008-08-25 16:23:27 UTC
Changed summary to follow NetCAT Etiquette
Comment 2 nvarun 2008-08-25 16:26:05 UTC
Changed the component and sub-component, as this is intended for that javascript.
Comment 3 Tomas Mysik 2008-08-25 17:58:23 UTC
Tor, if it's reproducible for you (for me it isn't), then it is probably quite important issue because nearly every 
PHP project has some JS files (as well as HTML and CSS files).

Product Version: NetBeans IDE Dev (Build 080824)
Java: 1.5.0_16; Java HotSpot(TM) Client VM 1.5.0_16-b02
System: Linux version 2.6.26-gentoo-r1 running on i386; UTF-8; cs_CZ (nb)

To reporter: could you please attach some sample project? It would be very helpful, thanks.
Comment 4 nvarun 2008-08-25 19:50:45 UTC
Created attachment 68272 [details]
Its a sample PHP app contains 2 zip files, one with metadata and other with src
Comment 5 nvarun 2008-08-25 19:52:49 UTC
Created attachment 68275 [details]
It contains 3 screenshots depicting the scenario
Comment 6 Marek Fukala 2009-04-24 16:20:05 UTC
That is normal behaviour, we offer all functions/vars of all .js files on the project classpath. This is because we
cannot perfectly find out the dependencies.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo