Bug 140603 - Support for CSS3
Support for CSS3
Status: VERIFIED FIXED
Product: web
Classification: Unclassified
Component: CSS Visual Tools
6.x
Sun All
: P1 (vote)
: 7.2
Assigned To: Marek Fukala
Jindrich Sedek
: PLAN
Depends on: 158658
Blocks: 150182 169679
  Show dependency treegraph
 
Reported: 2008-07-17 18:56 UTC by Jindrich Sedek
Modified: 2013-01-17 13:26 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
maincss (12.10 KB, text/css)
2012-01-29 17:59 UTC, aftermath
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jindrich Sedek 2008-07-17 18:56:00 UTC
use this code:
-------------
P{
   font-stretch: condensed ;
}
-------------

font-stretch property is marked as unknown, but it should not be since it's defined in CSS 2.0 specification - 
unfortunately it's not valid in CSS 2.1 specification, but it's valid again in CSS 3.0

the same problem appears for font-size-adjust property:
P{
  font-size-adjust: none;
}

maybe some warning should be shown about property invalidity in 2.1 CSS version, but "unknown property" is not very 
valuable information for user
Comment 1 Marek Fukala 2008-08-08 12:46:57 UTC
We currently support css 2.1 so this could be closed as as design. OTOH I am sure we need some css versions support, so
the user is able to set 'target' css version, maybe also target browser. If such version is choosen then the error is
valid. I'm not sure how hard would be to make a parser being able to parse all css versions and then just use semantic
analysis to make warnings for constructs not currently supported by choosen css version. I'll give it a try, but I am
affraid in next version, not 6.5 
Comment 2 Marek Fukala 2008-10-20 15:56:31 UTC
This issue should involve:
1) parsing based on css 1,2,2.1,(3.0) level
2) features like error checks, UI builder, completion behaves according to target version *and target browser*
Comment 3 Marek Fukala 2011-05-31 09:22:16 UTC
CSS2.1 is already supported. CSS 2.0 is outdated so what's currently missing is the css3 support.
Comment 4 aftermath 2012-01-29 17:59:28 UTC
Created attachment 115358 [details]
maincss
Comment 5 Marek Fukala 2012-10-15 11:57:25 UTC
css3 is already supported
Comment 6 Vladimir Riha 2013-01-17 13:26:16 UTC
verified


Product Version: NetBeans IDE 7.3 RC1 (Build 201301162100)
Java: 1.6.0_38; Java HotSpot(TM) Client VM 20.13-b02
Runtime: Java(TM) SE Runtime Environment 1.6.0_38-b05
System: Windows 8 version 6.2 running on x86; Cp1252; en_US (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo