Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 140537 - cannot remove keyboard shortcut on ant targets.
cannot remove keyboard shortcut on ant targets.
Status: VERIFIED FIXED
Product: projects
Classification: Unclassified
Component: Ant
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Jesse Glick
issues@projects
61fixes3-fixed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-17 14:40 UTC by nb_johan
Modified: 2008-09-04 13:22 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nb_johan 2008-07-17 14:40:27 UTC
I create an ant target shortcut. RightClick on a target -> Add a keyboard shourtcut -> I press a shortcut button. ->
press ok. Thats it. 
The shortcut cannot be removed. (unfortunately the shortcut was the <space> by mistake)
I try to replace it with another key. 
Now the problem is that both shortcut do the same think. 
So each time I press the space now I am getting a new build. 
I have looked on the keymap for sometime now but nothing.
Even if there is a setting somewhere in netbeans to set this it is so hidden, that I consider it a bug.
Comment 1 Jesse Glick 2008-07-18 20:32:39 UTC
I think I can fix it so the action at least shows up in the Keymap dialog where you can remove the binding. I don't
think this dialog is perfect yet - for example, seems to display the first such action I create but not the second
(without a restart of the IDE) - but should be enough.

core-main #edc823a485ef

To fix your own NB installation: go to the user directory (can be seen at top of View > IDE Log), and under
config/Shortcuts find the *.xml file and delete it.
Comment 2 Tomas Danek 2008-08-04 18:18:43 UTC
verified in 200807310201
Comment 3 rbalada 2008-08-04 21:12:18 UTC
I've transplanted the changeset http://hg.netbeans.org/core-main/raw-rev/edc823a485ef into release61_fixes repository as
http://hg.netbeans.org/release61_fixes/rev/727e48ab7527
Comment 4 Lukas Hasik 2008-08-21 09:43:25 UTC
verified in patch3 (2008-08-12_03-59-31)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo