Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 138364 - Move Enterprise Resources into Insert Code popup
Move Enterprise Resources into Insert Code popup
Status: RESOLVED DUPLICATE of bug 138360
Product: javaee
Classification: Unclassified
Component: EAR
6.x
All All
: P2 (vote)
: 6.x
Assigned To: David Konecny
issues@javaee
:
Depends on:
Blocks: 123450
  Show dependency treegraph
 
Reported: 2008-06-26 14:02 UTC by jrojcek
Modified: 2008-07-21 04:53 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jrojcek 2008-06-26 14:02:48 UTC
The editor contextual menu contains various actions generating code snippets (Insert Code, EJB Methods, Enterprise Resources, Web Service Client Resources). 
For 6.5 we want to clean up the menu and make the code generation consistent. This effort includes moving all code generating items from the contextual 
menu into the Insert Code popup. 

For the Enterprise Resources items it means the following:

- Add "Enterprise Bean Call...", "Database Usage...", "JMS Message Sending...", "E-mail Sending..." into the Insert Code popup
- Remove the "Enterprise Resources" submenu from the editor contextual menu

If there's more enterprise items in the menu, please let me know.
Comment 1 jrojcek 2008-06-26 14:03:48 UTC
This issue is part of the overall contextual cleanup planned for 6.5.
Comment 2 David Konecny 2008-07-21 04:53:40 UTC
All these actions are implemented in ejbcore module.

*** This issue has been marked as a duplicate of 138360 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo