Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 138360 - Move EJB Methods actions into Insert Code popup
Move EJB Methods actions into Insert Code popup
Status: RESOLVED FIXED
Product: javaee
Classification: Unclassified
Component: EJB
6.x
All All
: P2 (vote)
: 6.x
Assigned To: David Konecny
issues@javaee
:
: 138364 (view as bug list)
Depends on:
Blocks: 123450
  Show dependency treegraph
 
Reported: 2008-06-26 13:33 UTC by jrojcek
Modified: 2008-07-23 11:40 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
proposed fix (59.83 KB, text/plain)
2008-07-21 05:11 UTC, David Konecny
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jrojcek 2008-06-26 13:33:25 UTC
The editor contextual menu contains various actions generating code snippets (Insert Code, EJB Methods, Enterprise Resources, Web Service Client Resources). 
For 6.5 we want to clean up the menu and make the code generation consistent. This effort includes moving all code generating items from the contextual 
menu into the Insert Code popup.

For EJB module it means the following:

- Add a "Business Method..." item into the "Insert Code" popup.
- Remove the "EJB Methods" submenu from the editor contextual menu

If there's more EJB related items generating code, please let me know.
Comment 1 jrojcek 2008-06-26 13:36:00 UTC
This issue is part of overall contextual menu cleanup for 6.5.

Note that some file templates currently guide users towards the contextual menu for generating EJB code. The text in the templates needs to be updated as 
well to point users into the Insert Code popup.
Comment 2 David Konecny 2008-07-21 04:53:40 UTC
*** Issue 138364 has been marked as a duplicate of this issue. ***
Comment 3 David Konecny 2008-07-21 04:59:15 UTC
I thought this is implemented in project types but I was wrong -> passing back to ejb subcomponent. I have a fix which I
will attach diff of and Martin could you please skim it before I commit it. I'm not familiar at all with this area and
was following some existing Insert Code popup impl.

Also Jano mentioned some wizard referring to context menu - any pointers which one is it?
Comment 4 David Konecny 2008-07-21 05:11:32 UTC
Created attachment 65076 [details]
proposed fix
Comment 5 jrojcek 2008-07-22 15:28:15 UTC
I meant the actual text in the generated files. Some contain comments like:

// Right-click and select EJB Methods to generate...

I don't remember which templates generate code like that, but I've seen it a few times.
Comment 6 David Konecny 2008-07-22 22:39:13 UTC
Change implemented and templates updated.
962ae2c759fb
76f67037c875
ae56b18ff507
Comment 7 Quality Engineering 2008-07-23 11:40:41 UTC
Integrated into 'main-golden', available in NB_Trunk_Production #339 build
Changeset: http://hg.netbeans.org/main/rev/962ae2c759fb
User: David Konecny <dkonecny@netbeans.org>
Log: #138360 - Move EJB Methods actions into Insert Code popup


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo